iOS Question Hosted Mac vs Local build

wl

Well-Known Member
Licensed User
I have been struggling with keychain issues for many hours (see other threads) and it seems these kinds of issues popup regularly (found a topic of myself, I meanwhile forgot, from 2017)...

The answer is mostly: "use the simulator locally but hosted builder for deploy". I have been trying to fix the issues several times from a clean install of macOS and Xcode... So is there something we could learn from the setup of the hosted builder machines so local builds would be working better/always as well ?
 

aeric

Expert
Licensed User
I have been struggling with keychain issues for many hours (see other threads) and it seems these kinds of issues popup regularly (found a topic of myself, I meanwhile forgot, from 2017)...

The answer is mostly: "use the simulator locally but hosted builder for deploy". I have been trying to fix the issues several times from a clean install of macOS and Xcode... So is there something we could learn from the setup of the hosted builder machines so local builds would be working better/always as well ?
May I know which other thread? Can you post the link?

If I understand correctly, the difference between two machines is the updated libraries. For local builder, you need to keep your version up to date.
 
Upvote 0

wl

Well-Known Member
Licensed User
So strange, until now I have set up (all with Big Sur and latest Xcode, Bi 7.5 and related Builder)
- Mac mini 2014 i5: no issues whatsoever (did several installs and every one of them worked)
- Mac mini M1: could not get it to work
- Mac mini 2018, i7: could not get it to work
- Mac mini 2012, i7: could not get it to work

The issue I'm facing most is: "SecKeychainItemImport: Unknown format in import.". No-one else had this issue ? so strange ...
 
Upvote 0

wl

Well-Known Member
Licensed User
All of a sudden my local build start working on *all* environments (couldn't test the M1 environment yet though) ... As always: very hard to indicate what was going on:
what I (last) did was to create a CSR using the hosted builder environment, then used this CSR for the certificate, create an appId, provisioning profile and build a B4iBuilder app using the hosted builder environment: this worked.

Then used the same set of "key files" for the local builds ...

Update: now also working on an Apple M1...
I just have the impression that the creation of a CSR (?) and/or the certificate and/or the provisioning profile sometimes fails ...

So strange ...
 
Last edited:
Upvote 0
Top