Android Question How many and what different Android SDK Platforms i need to be installed?

sdesan

Member
Licensed User
Hi,
actually i have in Android SDK folder installed 8 different platforms version
android-14
android-21
android-23
android-24
android-25
android-26
android-28
android-Q


I need all this version installed (about 20 Gb for version) or i might deleted older version?
in my manifest usually i write
<uses-sdk android:minSdkVersion="10" android:targetSdkVersion="26"/>
so i can leave only android-26 folder/version or not?
Thank you in advance

Sergio
 

DonManfred

Expert
Licensed User
you should always have the newest platform installed (28) as it is the one b4a want to use.
Note that targetsdk is suggested to use 26 for now; but you should use the jar from platform 28.
Older platforms you don´t need to have installed.

PD: Sounds like you are using an OLD SDK. I suggest to install a new one (ready to run sdk is a good alternative).
 

Jorge M A

Well-Known Member
Licensed User
What about the AVD Manager and Emulator? (leaving aside their disadvantages).
Aren't these platforms necessary?
 
Top