iOS Question iMedia Library not liking me

morphe2011

Member
Licensed User
Longtime User
Or perhaps it is all of us? I am using iMedia 1.22 and it seems to be broken- sigh. I've tried both the regular example and the llCamera example. As soon as I call ll(or cam) .takepicture I get the following.

Any ideas?
Copying updated assets files (1)
Application_Start
SignalHandler 6
Application_Active
Application_Inactive
Error occurred on line: 73 (Main)
Signal - 6
Stack Trace: (
"0 B4i Example SignalHandler + 120",
"1 libsystem_platform.dylib 0x00000002174889e0 <redacted> + 40",
"2 libsystem_kernel.dylib 0x000000021740a80c <redacted> + 100",
"3 libsystem_kernel.dylib 0x000000021740a83c fcntl + 0",
"4 TCC <redacted> + 0",
"5 TCC <redacted> + 0",
"6 TCC <redacted> + 276",
"7 libxpc.dylib <redacted> + 60",
"8 libxpc.dylib <redacted> + 88",
"9 libdispatch.dylib <redacted> + 16"
)
 

morphe2011

Member
Licensed User
Longtime User
Hmmm. Just starting my Wednesday. The Error was off my iPad Mini with the latest OS Update. I will try it on my iPhone6S that has not been updated and advise.
 
Upvote 0

morphe2011

Member
Licensed User
Longtime User
Same Error. I am using version 1 of the demo app. Core 5.31 and iMedia 1.22. Any ideas? This is the log file:
Copying updated assets files (1)
Application_Start
Application_Active
SignalHandler 6
Error occurred on line: 55 (Main)
Signal - 6
Stack Trace: (
"0 B4i Example SignalHandler + 120",
"1 libsystem_platform.dylib 0x00000001bd6899e0 <redacted> + 40",
"2 libsystem_kernel.dylib 0x00000001bd60b80c <redacted> + 100",
"3 libsystem_kernel.dylib 0x00000001bd60b83c fcntl + 0",
"4 TCC <redacted> + 0",
"5 TCC <redacted> + 0",
"6 TCC <redacted> + 276",
"7 libxpc.dylib <redacted> + 60",
"8 libxpc.dylib <redacted> + 88",
"9 libdispatch.dylib <redacted> + 16"
)
 
Upvote 0

morphe2011

Member
Licensed User
Longtime User
And I just checked my two main devices. The iPad Mini is running 12.1.1. while the 6S got updated without me paying attention to 12.1.12. Both have worked in the past as recently as late last month
 
Upvote 0

morphe2011

Member
Licensed User
Longtime User
Good Day. This has nothing to do with permissions. It was working last month. It fails on the take picture command. The Camera briefly appears.

Sub btnTakePicture_Click
cam.TakePicture
End Sub
 
Upvote 0

morphe2011

Member
Licensed User
Longtime User
Good Day from a very cold western Canada. Is there any chance it is a B4i version issue? I am using 5.3. I will upgrade in the next few days. The log is the same on both current machines. I will try it later today on an older 5s running 10.3.3 is 32 bit mode.
 
Upvote 0

morphe2011

Member
Licensed User
Longtime User
After a lot of trial and error with permissions and different devices it is working on the iPad Mini at 12.1.1 but not the 6S on 12.1.12. Apple says that the stack errors are related to permissions and a deadlock. I have changed my app to have photos on one page and videos on the other. Not optimal but it is a custom app and the client will accept it that way. Not sure if this helps anyone else in any way
 
Upvote 0

David Meier

Active Member
Licensed User
I got the exact same error. I run the example program from Erel's post. The program crashed, when it invokes llc.StartPreview. I really thought there is an issue here but... read the next lines:


RESOLVED:
First things first: When I learned something in this forum it is do as Erel says …..
And he says:
Starting from iOS 10 you need to add an explanation on the camera usage:
B4X:
#PlistExtra:<key>NSCameraUsageDescription</key><string>Taking a photo and attach to the task.</string>

That's the solution :)
 
Last edited:
Upvote 0
Top