Android Question Issue with Maps library and API 28 upward

Jimdriver2

Member
Licensed User
Not sure if anyone else got this issue. Had a little search but couldn't see anything, so I thought I'd post this in case someone else does run into it.

Google Play Store now requires that apps target API 28 and upward. Doing so however causes the GoogleMaps library to then error and crash when running. To fix it you have to update your manifest to include:

<uses-library
android:name="org.apache.http.legacy"
android:required="false" />

In the AddApplicationText function.

I found out about that here:

https://developers.google.com/maps/documentation/android-sdk/config#specify_requirement_for_apache_http_legacy_library

Hopefully that helps others.
 
Top