B4J Question JGoogleMaps API Key - Solved

Discussion in 'B4J Questions' started by RichardN, May 22, 2019.

  1. RichardN

    RichardN Active Member Licensed User

    I was just updating an old utility that employs jGoogle Maps to find the library has been updated.

    Apparently his code is no longer supported:
    Code:
    gMap.Initialize2("gMap", options, APIkey)

    'instead it is now

    gMap.Initialize(
    "gMap", options)
    Consequently my map has 'Developer use only' plastered all over it. How do you now supply the API key?
     
    joulongleu likes this.
  2. Erel

    Erel Administrator Staff Member Licensed User

    Moved to the questions forum.

    GoogleMap.Initialize2 is still there.
     
  3. RichardN

    RichardN Active Member Licensed User

    Solved..... An older library erroneously copied to the C:\Program Files (x86)\Anywhere Software\B4J\Libraries folder.
     
    Last edited: May 22, 2019
  4. RichardN

    RichardN Active Member Licensed User

    Reading back in the forum.... It appears the issue of users incorrectly/accidently copying older libraries to the internal libs folder whilst expecting the IDE to pick up the intended version in 'AdditionalLibraries' is not new. This can cause all sorts of head scratching and time-wasting in trying to find the cause of such unexpected behavior.

    Perhaps the IDE could check for unexpected duplicates?
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice