iOS Question Local VM mac can't connect to iphone

watesoft

Active Member
Licensed User
debug mode:
hosted builder is ok.

I use win10 and vm macos 10.14 and xcode10.1
mac builder server is ok:
Build server is ready
https://192.168.32.128:51042
http://192.168.32.128:51041
Build server version: 5.50
Adding user to keychain: b4i_default
Compilation time: 40013, b4i_default, queue: 0, success: true.

http://192.168.32.128:51041/test is ok.
Fire wall is closed.

But my iphone can't connect to 192.168.32.128,so my app can't continue to debug.

No error happen in B4i and mac builder server, only iphone show "can't connect to 192.168.32.128 "
 
Last edited:

watesoft

Active Member
Licensed User
I have trusted the B4I certificate,but it is still not work. B4i-bridge can connect with IDE,but my iphone can't connect with Mac builder server IP, Perhaps I miss something,can you give me a step?

note: I have purchased hosted builder,it is very good and convenient to debug/release small App,but my App size is about 120M(mainly the database is a bit big),so I chose win10 and vm macos 10.14 and xcode10.1, mac simulator is ok,but real device is not work.
 

watesoft

Active Member
Licensed User
I want to make sure about this. There are two different steps here. It should look like this:

thanks Erel. I am sure that it is like this.In addition, I noticed that there will be a small window popping up on the screen, but it flashes past and can't judge what is going on.Since I don't know why, I am using the simulator temporarily.
 

sorex

Expert
Licensed User
are you sure your phone is also in the .32 subnet?

most of the time virtual machines have their network set as NAT and you need to change it to BRIDGED so that you get an IP address in the same range as your host machine (and iphone).
 

watesoft

Active Member
Licensed User
are you sure your phone is also in the .32 subnet?

most of the time virtual machines have their network set as NAT and you need to change it to BRIDGED so that you get an IP address in the same range as your host machine (and iphone).
I'm sure my iphone is also in the IPV4 subnet.
Wethere NAT or BRIDGED does not work.
 

sorex

Expert
Licensed User
I noticed that there will be a small window popping up on the screen
Do you mean that you open the bridge on the iphone and it closes again?

I had this a few days ago and my phone still had a bridge install with outdated certificate so I had to rebuild and re-install the bridge.

But as you are doing a new installation it's probably something else.

Can you access a webpage on another lan device from the phone? Maybe you wifi is in real hotspot mode then you can't access other devices over it.
 

tufanv

Expert
Licensed User
192.168.32.128 is not a correct ip I think. Close the VM. Open up the network adapter settings in vmware. Check the "Bridged" mode under settings and try again.
 

watesoft

Active Member
Licensed User
If it works with the hosted builder and the B4I certificate is properly trusted then it should work with the local builder as well. If it doesn't work then it is probably related to the network configuration.
Thanks Erel,The problem is solved.
In the past,desktop computer connected to the Internet via a network cable,and a USB portable router was plugged into desktop computer.My laptop computer and iphone accepted the wifi signal of the USB router.This is the wrong way,so it didn't work always.
Now,Directly I connect to the Internet via a network cable using a standard router,My laptop computer and iphone accepted the wifi signal of the standard router,wow it does work.
 
Top