B4J Question MacSigner Link Error


Licensed User
I have been using the MacSinger successfully and then recently I cannot get pass the first step. I get the error below when I link. I am probably doing something obviously wrong. In addition, I tried running MacSigner on older Mac and it ran fine. My old version is Catalina 10.15.7 and new version is Monterey 12.4. Xcode is 12.4 on both. Any help would be welcome.

packager.json not found. Using default properties.
B4JPackager11 Version 1.40
Exe name: jar.exe
build folder: /Users/sandrachao/Dropbox/CUP Communications Team Folder/B4XPages/Programs/BridgeDealerPlus - Now/B4J/Objects/temp/temp/build
InputJar: /Users/sandrachao/Dropbox/CUP Communications Team Folder/B4XPages/Programs/BridgeDealerPlus - Now/B4J/Objects/temp/jar.jar
Running: /Users/sandrachao/Documents/java/jdk-14.0.2.jdk/Contents/Home/bin/jar

java.util.zip.ZipException: zip file is empty
at java.base/java.util.zip.ZipFile$Source.zerror(ZipFile.java:1502)
at java.base/java.util.zip.ZipFile$Source.findEND(ZipFile.java:1310)
at java.base/java.util.zip.ZipFile$Source.initCEN(ZipFile.java:1404)
at java.base/java.util.zip.ZipFile$Source.<init>(ZipFile.java:1209)
at java.base/java.util.zip.ZipFile$Source.get(ZipFile.java:1172)
at java.base/java.util.zip.ZipFile$CleanableResource.<init>(ZipFile.java:717)
at java.base/java.util.zip.ZipFile.<init>(ZipFile.java:237)
at java.base/java.util.zip.ZipFile.<init>(ZipFile.java:167)
at java.base/java.util.zip.ZipFile.<init>(ZipFile.java:138)
at jdk.jartool/sun.tools.jar.Main.extract(Main.java:1357)
at jdk.jartool/sun.tools.jar.Main.run(Main.java:375)
at jdk.jartool/sun.tools.jar.Main.main(Main.java:1649)

Link completed unsuccessfully.
Last edited:


Licensed User
Things to try:
1. Move the project outside of the dropbox folder.
2. Move it to a folder without spaces.
Thanks for the tips. They did not seems to help.

I have a question. During link, are there any files that are used that can get corrupted? I tried redownloading
files below and it did not help. I tried updated to the latest Xcode with no effect.

Java JDK 14.0.2
JavaFX libs
JavaFX jmods

It is curious that it is working on an older Mac and it was working on my newer Mac until recently. You mention that
MacSigner uses B4JPackager11. Is there a test I can implement with B4JPackager11? Does it have any dependencies that
can get corrupted?
Upvote 0


Licensed User
My guess is that the input jar is the problem. It looks it is empty.
I found the problem. Thank you for your patience. It was a Dropbox sync issue. There is a known Dropbox problem with newer MacOS 12.3 and above. The .jar file was defaulted on the cloud. After I downloaded it, it worked. If anyone else has this Dropbox Sync issue, do the following:

In Finder, check if there is a "cloud icon" next to file rather than a "green checkmark". If so, make the online-only file available to open in third-party applications by:
1. Open your Dropbox folder in Finder.
2. Right-click the file you want to have available.
3. Click “Make available offline.”
Last edited:
Upvote 0

Similar Threads