Android Question Maven artifact not found com.google.firebase/firebase-ads

Discussion in 'Android Questions' started by Greg Conely, Aug 25, 2019.

  1. Greg Conely

    Greg Conely Member Licensed User

    I have recently upgraded to the latest version of B4A
    upload_2019-8-25_12-31-21.png

    and opened an existing project to implement ads. I have gone through the instructions but continue to receive the following error. I have also tried running with a brand new blank app and get the same error as soon as I try to add the library to the project or attempt to build any project that has this library checked.

    An error occurred.
    Maven artifact not found:
    com.google.firebase/firebase-ads

    upload_2019-8-25_12-24-43.png

    What I have installed pretty much everything firebase in the SDK manager:
    upload_2019-8-25_12-28-45.png


    My paths setup:
    upload_2019-8-25_12-25-47.png

    I am running this on a Windows 10 machine, completely up to date.


    Here is a copy of the log file from running b4a.exe -log
    ----------------

    Build modules tree: 0
    B4A version: 9.30
    .Net version: 4.0.30319.42000
    Ini folder: C:\Users\greg\AppData\Roaming\Anywhere Software\Basic4android
    UDP server: 192.168.1.110, broadcast: 192.168.1.255
    Java version: 11
    Gui: 1008
    Build modules tree: 0
    Gui: 1014
    Gui: 1000
    File not found: Starter.bas
    Build modules tree: 2
    File not found: Starter.bas
    File not found: Starter.bas
    *** no reuse ***
    *** no reuse ***
    Gui: 128
    Build modules tree: 3
    Build modules tree: 0
    *** no reuse ***
    *** no reuse ***
    Gui: 194
    Build modules tree: 1
    Gui: 199
    ExitCode: 1
    Output:
    jarsigner: unable to open jar file: bin\temp.ap_

    Error:

    jarsigner: unable to open jar file: bin\temp.ap_

    System.Exception: Maven artifact not found: com.google.firebase/firebase-ads
    at hb.d(hc A_0, ICollection`1 A_1)
    at ha.a(e6 A_0, Dictionary`2 A_1, ICollection`1 A_2)
    at ha.a(e6 A_0, hh A_1)
    at l.c()
    at f0.a(Object A_0)
    Compilation task: 183.9921
    --------------


    Any suggestions or ideas you have, please let me know.

    Thanks - Greg
     

    Attached Files:

    Last edited: Aug 25, 2019
  2. DonManfred

    DonManfred Expert Licensed User

    you are not using the same sdk.
    your sdk is in c:\androidsdktools so the path to android.jar should be c:\androidsdktools\platforms\android-28\Android.jar

    PS: It is a mistake to put the SDK into the programfiles folder as this is a restricted folder.
     
  3. Erel

    Erel Administrator Staff Member Licensed User

    1. Moved to the questions forum.
    2. The post is unreadable due to the huge images.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice