Android Question Maven artifact not found: com.google.guava/listenablefuture (SOLVED)

Greg Breinholt

Member
Licensed User
Just updated the SDK through the B4A SDK Manger and now I get the "Maven artifact not found: com.google.guava/listenablefuture".

I tried searching for it, and this is closest one installed:
1603194708865.png


I see that others had this issue in the past - seems that updates to the SDK Manager to 3.6 fixed it last time:

I also tried copying the resources over, as noted here:
https://www.b4x.com/android/forum/threads/b4a-v10-2-beta-is-available-for-download.121775/

Anyone else getting this and know how to fix?

EDIT: SOLVED
See the file attached by Erel at the end of this thread.
 
Last edited:

Greg Breinholt

Member
Licensed User
I think it's the Firebase Ads (not at computer, so name might not be exactly right). Checked: FirebaseAdMob
 
Last edited:

trepdas

Active Member
Licensed User
hi
had the same problem.
I simply reinstalled b4a latest version and updated the sdk with the needed resources and now all works ok.
 
Last edited:

Scantech

Well-Known Member
Licensed User
I've just updated all recommended items. One new item was needed: android.x/work-runtime
I installed it and everything seems to compile fine.

Make sure that the SDK version logged when you start B4A sdk manager is:
SDK version: 6609375
I installed the android.x/work-runtime and have 6609375 and still no good here.
 

Greg Breinholt

Member
Licensed User
Hmmm... my SDK shows as this:

1603340103664.png


How do I force this to be updated? (I copied the required resources, etc.)

PS Really appreciate the help I'm getting. Just love B4A and the community!
 

Greg Breinholt

Member
Licensed User
I've followed those instructions carefully (more than once!) - originally, when I first setup B4A, plus serval times in the last few days when I started getting the error.
My SDK number still does not match the number above, and I'm still getting the "com.google.guava/listenablefuture" error.

Are those instructions the only way to update the SDK from 4333796 -> 6609375? (cause that's not working for me)
 

Greg Breinholt

Member
Licensed User
OK... deleted the whole Android SDK folder, extracted the 2 packages..... and I did now see 6609375 (win!) - but the original error popped up immediately ;-(
Ran the recommended updates (took a bit of time as it downloaded all the deleted tools, had to accept he license, etc.)

When trying to build, had these errors, so searched in the SDK Manager and added these:
Maven artifact not found: androidx.annotation/annotation-experimental
Maven artifact not found: androidx.viewpager2/viewpager2
Maven artifact not found: androidx.work/work-runtime


But still got this:
Maven artifact not found: com.google.guava/listenablefuture


I'll try the same thing again later, without running the updates and see whether that works (but as it immediately popped-up from the Libraries, something still not right).
Is this the right version?
1603347300814.png
 
Top