1. *** New version of B4J is available ***
    B4J v7.8
    Dismiss Notice

iOS Question minimum xcode version works fine with B4i v5.30

Discussion in 'iOS Questions' started by Modern_Digital, May 4, 2019.

  1. Modern_Digital

    Modern_Digital Member Licensed User

    Hi,

    I want to know what is the minimum xcode version can i use with B4i v5.30 and what the minimum value can i put in #MinVersion in my projects .

    Note :
    - I have Mac computer running macos v10.13.6 .
    - I have B4i v5.30 .

    Thank you.
     
  2. aeric

    aeric Active Member Licensed User

    I think we only can download the latest version of Xcode which is version 10.0+ if you are using macOS 10.13.6.
    I think Xcode 9.3 is supported in B4i v5.00 but it depend on the version of macOS.

    https://en.wikipedia.org/wiki/Xcode#Version_comparison_table

    I normally just leave to the default value when starting a new project.

    Code:
    #MinVersion: 8
     
    Modern_Digital likes this.
  3. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    All apps uploaded to App Store must be built with the iOS 12.1 SDK or later. The earliest version of Xcode that supports the 12.1 SDK is 10.1.

    - Colin.
     
    anOparator and Modern_Digital like this.
  4. Modern_Digital

    Modern_Digital Member Licensed User

    Thanks a lot for you guys, Thats true i figureout that any app from march,2019 must be built in sdk 12.1 or later and ofcurse using xcode 10.1 or later , But guys, that means the #MinVersion should be 12.1 is it true or not.
     
  5. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    I don't use B4i but in B4A #Minversion is the earliest version of Android the app supports, so I assume it's the same in B4i. If you set it to 12.1 your app will only run on devices running iOS 12.1 & later. I generally support iOS 8.x & up, but it depends on what features are in your app & what is the earliest SDK they are supported in.

    Note that the Xcode version & #Minversion aren't related. You can build an app using the 12.1 SDK, but it can still run on devices running earlier versions of iOS, depending on what you set #Minversion to.

    - Colin.
     
    Modern_Digital likes this.
  6. Modern_Digital

    Modern_Digital Member Licensed User

    Thanks a lot Colin for the information it's really helpful for me, I want to mention that I tested my app on xcode simulator running ios 9.3 and my app did not work, It's crashes when I try to open it, Thats what made me think I should put #MinVersion to 12.1 .
     
  7. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    If you put #Minversion 12.1 then it definitely won't run on an iOS 9.3 device. Try creating a new thread with details of the crash & the error message(s) you're seeing & somebody might be able to help you solve it.

    - Colin.
     
    Modern_Digital likes this.
  8. Modern_Digital

    Modern_Digital Member Licensed User

    Hi Colin ,

    I did not put #MinVersion to 12.1 when I tested my app on simulator ios 9.3 the #MinVersion was 7 then crashes happned.

    Thank you.
     
  9. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    Yeah - I figured that. Just saying that if you do change #Minversion to 12.1, it won't run. You're probably OK with setting the #Minversion to 9.0 because there are very few devices still running anything older than that -> https://david-smith.org/iosversionstats/

    - Colin.
     
    Modern_Digital likes this.
  10. Modern_Digital

    Modern_Digital Member Licensed User

    Thank you very much Colin, Your help is greate and the link is very nice and very helpful i really appreciate your help, Have a nice day.
     
    Computersmith64 likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice