Italian mysql connector-java.8.0.15

mostosoft

Member
Licensed User
ciao a tutti, sto cercando di connettermi a mysql col connettore in oggetto ma ottengo sempre
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)

hi everybody,
if I use this connector, I obtain this error
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)

how can I fix it? I've alrealdy installed to android-sdk 26, manifest is ok, a java version is 1.8

thanks
mic
 

sirjo66

Well-Known Member
Licensed User
non ho idea di cosa stai parlando, ma mi sembra che leggendo il codice di errore la cosa sia abbastanza chiara, e cioè che devi impostare un SDK con valore 26 o superiori, probabilmente per versioni di OS inferiori non è contemplato
 

mostosoft

Member
Licensed User
non ho idea di cosa stai parlando, ma mi sembra che leggendo il codice di errore la cosa sia abbastanza chiara, e cioè che devi impostare un SDK con valore 26 o superiori, probabilmente per versioni di OS inferiori non è contemplato
grazie per la risposta, penso a questo punto che all'SDK 26 (che ho già installato) manchi qualche pacchetto extra, non capisco altrimenti
 

sirjo66

Well-Known Member
Licensed User
installazione ok, ma hai detto al compilatore che deve usarlo ??
Come ti ha detto Luca devi specificarlo nel file manifest
 

mostosoft

Member
Licensed User
ho reinstallato android 26 dalla sdk e indicato al manifest di utilizzarlo ma niente sempre lo stesso errore.
 

mostosoft

Member
Licensed User
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="28"/>
C:\Program Files (x86)\Android\android-sdk\platforms\android-26\android.jar
 

mostosoft

Member
Licensed User
ottengo anche questo commentando la AdditionalJar che richiede la 26:
adb: failed to install appuntamenti_ver2_RAPID_DEBUG.apk: Failure [INSTALL_FAILED_OLDER_SDK: Failed parse during installPackageLI: /data/app/vmdl905581981.tmp/base.apk (at Binary XML file line #9): Requires newer sdk version #26 (current version is #25)]
 

mostosoft

Member
Licensed User
sia nel manifest che nel config path gli dico di utilizzare la 26..c'è qualche altro file di configurazione in cui viene indicata la versione sdk da utilizzare?
 
Top