Android Question Rapid_Debug.apk: Failure (Solved)

Shelby

Active Member
Licensed User
Starting to change an app I have (not yet registered) I copied and pasted my app into a new B4A container and after I run the AVD manager and start to run the new app, I get the following error.
B4X:
B4A Version: 9.30
Java Version: 8
Parsing code.    (0.00s)
Building folders structure.    (0.03s)
Compiling code.    (0.03s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (0.01s)
    (AndroidX SDK)
Generating R file.    (0.16s)
Compiling debugger engine code.    (0.89s)
Compiling generated Java code.    (1.00s)
Convert byte code - optimized dex.    (0.46s)
Packaging files.    (0.24s)
Copying libraries resources    (0.00s)
Signing package file (debug key).    (0.62s)
ZipAlign file.    (0.85s)
Installing file to device.    Error
adb: failed to install AreaWalls_RAPID_DEBUG.apk: Failure [INSTALL_FAILED_VERSION_DOWNGRADE]
I changed the manifest editor target version to read: 27, then 28 and still no success. Is there some other problem I don't see?
Thanks
 

Shelby

Active Member
Licensed User
I now see that I haven't transferred my designer over to the experimental project. I'll try that while I await some merciful soul who might help me.
 

yfleury

Active Member
Licensed User
Just uninstall the app on your device and install the new one

Or
Change version in new app to the same version number or higher in your app
 

Shelby

Active Member
Licensed User
Thanks, I'm not sure I understand but I'll try. I'm using the emulator (B4A). Oh!!! Yes I remember that. Great!
Thanks
I assume that the version # is in the manifest editor?
 

Shelby

Active Member
Licensed User
Oh yes, it's been months since I had to change one of these.

Initially thinking that changing the version code worked was a mistake by me. I had to first find the highest version code that I had used before. After adding 1 to that number I finally had success.

Thanks again yfleury
 
Last edited:
Top