B4J Question Raspberry 3B with Buster Lite 32 bits - B4J GUI not working


Well-Known Member
Licensed User
Longtime User
I've downloaded the Java 11 JDK on my Raspberry Pi 3B+ as per official instructions from this board:
wget -N https://github.com/bell-sw/Liberica/releases/download/11.0.1/bellsoft-jdk11.0.1-linux-arm32-vfp-hflt-lite.tar.gz
tar -xvf bellsoft-jdk11.0.1-linux-arm32-vfp-hflt-lite.tar.gz

I've created a simple "Hello World" non-GUI jar file with B4J, which I run with:
sudo /home/username/jdk-11.0.1/bin/java -jar /home/username/helloworld.jar

That WORKS! Yihaa!

Next step: a simple GUI window with a button, basically the standard code that shows up when you create a GUI B4J project. When I'm trying to run that, I get an error:

java.lang.NoClassDefFoundError: Could not initialize class com.sun.javafx.text.GlyphLayout

I thought, well, that could be normal since JavaFX is not included in the minimal installation of Liberica. So I did this:

wget -N https://github.com/bell-sw/Liberica/releases/download/11.0.1/bellsoft-jdk11.0.1-linux-arm32-vfp-hflt.tar.gz
tar -xvf bellsoft-jdk11.0.1-linux-arm32-vfp-hflt.tar.gz

However, same error.

Should I activate the GL driver using raspiconfig? Is that the key to success?