Android Question Run b4a on mac via crossover

Discussion in 'Android Questions' started by omidaghakhani1368, Jun 1, 2015.

  1. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Hi to all.
    I can execute b4a and b4i and b4j on mac via crossover.
    I do all of step for execute b4a.
    But when compile project i get error that i decide to ask from you if you know how solve it
    [​IMG]
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Try to increase the VM allocated ram.
     
  3. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Thank you erel.But in corssover how i can increase vm allocated ram?
    Crossover dont have Environment variable
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    I'm sorry but I'm not familiar with Crossover. Based on the error message it seems that it is running out of memory.
     
  5. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Thank you.If i can run b4x on mac via crossover then come in b4a family in mac :)
    I try again
     
  6. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Erel,in configure path,where is save java path?
    i want to change command line to increase heap size example c:\program files\java\jdk\bin\java.exe -Xmx512m
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    You can increase the heap size by setting MaxRamForDex in the ini file.
     
  8. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Where is ini file? :(
     
  9. timbald

    timbald Member Licensed User

  10. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Thank you but i like to run b4a without parallel desktop.
    I can run b4a and match java but i get error.
     
  11. Erel

    Erel Administrator Staff Member Licensed User

  12. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

  13. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

  14. Erel

    Erel Administrator Staff Member Licensed User

    All that I can say is that there is a network problem.
     
  15. marno

    marno Member Licensed User

    Hi omidaghakhani1368!

    How did you get b4a working with crossover. I can't even start it.
    Which dependencies did you install? Which Bottle?

    Thank you

    Marius
     
  16. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Hi.
    When install b4a in crossover,you should be install framework 3.5 on b4a bottle and then install java on b4a bottle
    I can make film for you
     
  17. marno

    marno Member Licensed User

    Ahh, cool. Thank you.
    First Step you do is to install b4a?
    Then Dot Net 3.5? 4.0 doesn't work?
    Last thing you do is to install java? Which Version?

    When I start B4A I see the "open File" Dialog, where I choose the License-File.
    After that I get an empty Modal or something like that in my Desktop. After that nothing happens...

    [​IMG]
     
    Last edited: Jun 24, 2015
  18. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    after install b4a and open it,you must enter license and email and successfully license.
    after install .net framework on bottle b4a
     
  19. marno

    marno Member Licensed User

    Ok, I did't get anything running.
    With Dot Net 3.5 as you mentioned B4A completely doesn't start, telling me that it need 4.0.
    Installing that, I get the chance to choose the license file, but no Input for email etc. only the empty modal widow as shown before.
    So, it would be nice if you can show me your steps in a video.
    Which Version of MAC OS do you have? Which Version of crossover?

    Thank you for your help

    Marius
     
  20. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    I use crossover 14 and Yosemite 10.10.2
    I install b4a 4.3 not b4a 5.
    When install b4a and .net framework and run b4a,it run and request license file.isn't?
     
Loading...