Android Question [Solved] Compile Error: Uncaught translation error.

Discussion in 'Android Questions' started by Kwame Twum, Jun 10, 2018.

  1. Kwame Twum

    Kwame Twum Active Member Licensed User

    Hello everyone,

    I opened up a project(targets API 24) and attempted to compile but it failed with an error. It compiled successfully the last time I opened it (12 days ago), and the resulting app from that last compile is even on the play store, so I know I haven't added any new library to conflict classes.

    I even downloaded one of my old successfully compiling backups (which goes back 5 app versions and targets API 21). When I tried to compile that too, it failed with the exact same error.

    I've done extensive readings throughout the forum and know this form of error usually refers to possible coincidences of libraries referencing the same class. But like I mentioned, I haven't added any other library after the last successful compile. (And even if I have, the old backup still fails to compile)

    I need help. The error log is as follows;

    Code:
    B4A Version: 8.00
    Parsing code.    (
    1.46s)
    Compiling code.    (
    8.81s)
    Compiling layouts code.    (
    0.53s)
    Organizing libraries.    (
    13.09s)
    Generating R 
    file.    (3.63s)
    Compiling debugger engine code.    (
    19.88s)
    Compiling generated Java code.    (
    24.38s)
    Convert byte code - optimized dex.    Error
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LA;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LB;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LC;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LCode;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LD;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LF;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LH;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LI;
    Uncaught translation error: java.lang.IllegalArgumentException: already added: LL;
    UNEXPECTED TOP-LEVEL 
    EXCEPTION:
    java.lang.RuntimeException: Translation has been interrupted
       at com.android.dx.command.dexer.Main.processAllFiles(Main.java:
    689)
       at com.android.dx.command.dexer.Main.runMonoDex(Main.java:
    313)
       at com.android.dx.command.dexer.Main.run(Main.java:
    279)
       at com.android.dx.command.dexer.Main.main(Main.java:
    247)
       at com.android.dx.command.Main.main(Main.java:
    106)
    Caused by: java.lang.InterruptedException: Too many errors
       at com.android.dx.command.dexer.Main.processAllFiles(Main.java:
    681)
       ... 
    4 more
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Create a new project and run it. Does it work?
     
  3. Kwame Twum

    Kwame Twum Active Member Licensed User

    Thanks for the response @Erel. A new project runs. My other projects compile successfully too.

    I've even tried to export the failing project as zip but the IDE complains of missing files which shouldn't even exist. (for instance, I have a file named g_1f447.png... nd during the export, the IDE complains of 1f447.png rather being missing)
     
  4. Kwame Twum

    Kwame Twum Active Member Licensed User

    Hello again, Apparently I upgraded a few of the enabled libraries in the project. So I reverted back to the older versions of those libraries and the project compiled successfully again.

    I updated the libraries one after the other and found the culprit was the latest version of B4AGridView. I'm already using other libraries from the developer so I believe the conflict was introduced after the update.

    Thanks for the assistance @Erel
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice