B4J Question [SOLVED] jStringUtils error?

Discussion in 'B4J Questions' started by micro, Oct 22, 2017.

  1. micro

    micro Well-Known Member Licensed User

    Hi to all
    this's a error on raspberry with LoadCsv(jStringUtils library function)

    Code:
    Log(File.Exists("/mnt/usb/", namef)) 'true, test file the file is present
    table = su.LoadCSV("/mnt/usb/", namef, ";")
    'Or
    table = su.LoadCSV("/mnt/usb", namef, ";")
    'java.lang.StringIndexOutOfBoundsException: String index out of range: -996
    With
    Code:
    table = su.LoadCSV("mnt/usb", namef, ";")
    'java.io.FileNotFoundException: mnt/usb/format.csv (File o directory non esistente)
    The correct path is "/mnt/usb/" infact with FileExists work.
    The version of jstringUtils is 1.00
    Thanks
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Can you post the full error message from the logs?
    What is the output of File.ReadString(<path here>) ?
     
  3. micro

    micro Well-Known Member Licensed User

    [SOLVED]
    Excuse me
    but it worked fine was a problem on the separator
     
  4. Cableguy

    Cableguy Expert Licensed User

    You should edit the post title and add the prefix [SOLVED] to it
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice