B4J Question Error when running the executable from B4J Packager11

Zeppah

Member
When I run debug that the program provides I get:


C:\B4X\B4J\B4J Exacutables\Math Trainer>cd bin

C:\B4X\B4J\B4J Exacutables\Math Trainer\bin>java.exe @release_java_modules.txt -m b4j/b4j.MathTrainer2.main
mathtrainer._show (java line: -1)
java.lang.UnsupportedOperationException: Unsupported protocol "jrt"
at javafx.media/com.sun.media.jfxmedia.locator.Locator.<init>(Unknown Source)
at javafx.media/javafx.scene.media.Media.<init>(Unknown Source)
at b4j/anywheresoftware.b4j.objects.MediaPlayerWrapper.Initialize(Unknown Source)
at b4j/b4j.MathTrainer2.mathtrainer._show(Unknown Source)
at b4j/b4j.MathTrainer2.login._btnlogin_click(Unknown Source)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at b4j/anywheresoftware.b4a.BA.raiseEvent2(Unknown Source)
at b4j/anywheresoftware.b4a.BA$1.run(Unknown Source)
at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$10(Unknown Source)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$11(Unknown Source)
at javafx.graphics/com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)
at javafx.graphics/com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
at javafx.graphics/com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)


C:\B4X\B4J\B4J Exacutables\Math Trainer\bin>pause
Press any key to continue . . .
===========================================================================

I searched for "Unsupported protocol "jrt"" but haven't found anything yet.

Any ideas?
 

Zeppah

Member
I now realize I asked this question in the wrong place. The B4J Packager 11 worked. After I ran the .iss file through the Inno Setup Compiler I tried to run the .exe that was produced. That program crashed. When I ran the run_debug.bat that the Compiler generated, I saw the error message. So, I think that the problem is on their end and not ours!

If I am wrong, please let me know.

Thank you for looking into my question!
 
Upvote 0

Zeppah

Member
Great! Thanks

After reading the information at the bug link you provided, the problem seems to be the sound files I use for correct and incorrect answers. I don't know enough, yet, to produce sounds another way. I was considering just taking that feature out!
 

Attachments

  • Math Trainer.zip
    182.9 KB · Views: 138
Last edited:
Upvote 0
Top