Android Question Tappx ads service failed to load banner ad

trueboss323

Active Member
Licensed User
I am using this library to display ads: https://www.b4x.com/android/forum/threads/tappx-ads-service.90624/#content
But I keep getting an error message when I try to load a banner ad:
onBannerLoadFailed: (ArrayList) [com.tappx.sdk.android.TappxBanner{12a9513 V.E...... ........ 0,0-480,75}, NO_FILL]
I cannot figure out why , I checked my key is correct, I've tried on AVD and a real device, I tried on release mode, all the same thing.
Also how can I place the ad banner at the bottom of the screen?
 
Last edited:

trueboss323

Active Member
Licensed User
I've been getting that NO_FILL error for a while now. Is there another reason why I could not be getting any ads , is there a setting I can change?
 

trueboss323

Active Member
Licensed User
This is very weird, I just tried adding a 0 to the end of the Tappxkey to test if I get another error, but no, my banner ads started to show. If I remove the "0" back to my original key, then I get the NO_FILL error again. Then I try adding a "1" , banner ads load again. Now my ads are loading, but I still don't understand why.
 

Computersmith64

Well-Known Member
Licensed User
This is very weird, I just tried adding a 0 to the end of the Tappxkey to test if I get another error, but no, my banner ads started to show. If I remove the "0" back to my original key, then I get the NO_FILL error again. Then I try adding a "1" , banner ads load again. Now my ads are loading, but I still don't understand why.
Try contacting Tappx support - they are usually pretty responsive. I've found a couple of bugs in their SDK in the past they they have fixed reasonably quickly.

- Colin.
 
Top