Android Question The Android App Bundle was not signed

1. Check Tools - Private Sign Key. Look for the public key algorithm. If it isn't an old key then it should show 2048-bit RSA key.
2. Assuming that this is the case, add this line:
#SignKeyAlgorithm: -digestalg SHA-256 -sigalg SHA256withRSA

3. If you are using an old key then submit an APK instead of AAB. There are no advantages for AABs.


Active Member
Licensed User
Longtime User
Im here reporting the same problem, trying closing IDE and reopening, no fix
Upvote 0

Sergio Haurat

Active Member
Licensed User
Longtime User
B4A Version: 12.50
Parsing code. (0.13s)
Java Version: 14
Building folders structure. (0.08s)
Running custom action. (0.03s)
Compiling code. (0.12s)

ObfuscatorMap.txt file created in Objects folder.
Compiling layouts code. (0.01s)
Organizing libraries. (0.05s)
(AndroidX SDK)
Compiling resources (0.45s)
Linking resources (0.38s)
Compiling generated Java code. (2.44s)
Finding libraries that need to be dexed. (0.00s)
Dex code (1.58s)
Dex merge (3.57s)
Copying libraries resources (2.72s)
Building app bundle (1.33s)
Signing AAB file (2.64s)
Algorithm: -digestalg SHA1 -sigalg SHA256withRSA
Output file: C:\Basic4All\PSA Handball\B4A\Objects\result.aab
Completed successfully. :rolleyes:
Upvote 0


Active Member
Licensed User
Sergio Haurat,

Yes understandably we all can compile and got the app signed in B4A. But when we upload the .aab, Google Play Console says :
'The Android App Bundle was not signed.'
Upvote 0


Licensed User
Longtime User
It looks like you can upload an APK even if you previously uploaded an AAB. Try it as a temporary solution.
I tried it already and it is not possible. At least i got an error when i tried to upload an apk instead of aab
Upvote 0


Licensed User
Having the same problem. Probably a Google Play error. I have always loaded .aab files, I tried to upload the .apk but it is not accepted.
Upvote 0