Android Question unable to compile after 10.9 upgrade

Gianni Sassanelli

Active Member
Licensed User
Hi
i have error on compilation after upgrade B4a from 9.01 to 10.9
the error is the following
I have updates the sdk as suggest in other thread but unsuccessfully
I have tried with empty project and the error is the some

Help me please
yhanks


Error response on compilation

B4A Version: 11.00
Parsing code. (0.02s)
Java Version: 8
Building folders structure. (0.03s)
Running custom action. (0.06s)
Compiling code. (0.07s)
Compiling layouts code. (0.01s)
Organizing libraries. (0.00s)
(AndroidX SDK)
Compiling resources (0.09s)
Linking resources (0.33s)
Compiling debugger engine code. (1.05s)
Compiling generated Java code. (1.02s)
Convert byte code - optimized dex. (0.46s)
Copying libraries resources (0.14s)
ZipAlign file. (0.06s)
Signing package file (private key). Error
Unsupported option: --v3-signing-enabled. See --help for supported options.
 

agraham

Expert
Licensed User
I have updates the sdk as suggest in other thread but unsuccessfully
That error seems to indicate that you are still using an old SDK. Try again following the instructions exactly. Don't run SDK Manager and ensure that your IDE path points to the new Android-30 SDK android.jar.
 
Upvote 0

Xfood

Well-Known Member
Licensed User
follow this guide

 
Upvote 0
Top