Android Question Updated to okhttp v1.50, now it won't compile


Active Member
Licensed User
Longtime User
I just downloaded and copied the new version of okhttp into the libraries directory and now i can't compile anymore, I get this error:

B4A Version: 11.20
Parsing code.    (0.15s)
    Java Version: 11
Building folders structure.    (0.05s)
Running custom action.    (0.02s)
Compiling code.    (0.20s)
Compiling layouts code.    (0.01s)
Organizing libraries.    (0.00s)
    (AndroidX SDK)
Compiling resources    (0.03s)
Linking resources    (0.26s)
Compiling generated Java code.    (0.02s)
Convert byte code - optimized dex.    Error
unsupported class file version 53.0
...while parsing META-INF/versions/9/module-info.class
1 error; aborting

I have tried openJDK11 and JAVA8 and both give the same error. After reverting to the previous version it compiles well.

And here are the libraries i am using (okhttputils2 depends on okhttp):
Last edited:


Active Member
Licensed User
Longtime User
The problem was in kotlin-stdlib-1.6.10. I've uploaded a new package. Same link as before.
For help & clarification, is it an individual download, or part of a package? i.e. Repeating the here link would be helpful.
Upvote 0


Licensed User
Longtime User
isn't it more fun to spend hours trying to find it? it's here
don't forget to unzip it into the main anywheresoftware folder (b4a --> libraries), not in your add'l libraries folders
Upvote 0