Android Question ZipAlign not found

Discussion in 'Android Questions' started by jcesar, Mar 28, 2015.

Similar threads

B4A Tutorial AndroidX SDK
B4A Tutorial Google Play App Signing
B4A Question Zipalign cannot be find.
B4A Question Can't find ZipAlign file
B4A Question ZipAlign has no path
Games [XUI2D] Example Pack
  1. jcesar

    jcesar Active Member Licensed User

    After upgrade the sdk manager i cant compile apps with B4A.

    Get this error:

    Code:
    Parsing code.                           0.08
    Compiling code.                         
    0.33
    Compiling layouts code.                 
    0.06
    Generating R 
    file.                      0.11
    Compiling generated Java code.          
    1.91
    Convert byte code - optimized dex.      
    5.13
        Optimized dexer failed. Switching 
    to Standard dexer.
    Packaging files.                        
    0.72
    Copying libraries resources             
    0.03
        Found 
    11 resource files.
    Signing package 
    file (private key)      0.76
    ZipAlign 
    file.                          Error
    Cannot find:
    Please configure paths (Tools - Configure Paths).
     
  2. NJDude

    NJDude Expert Licensed User

    Try reinstalling the SDK from scratch, there was an issue but it has been resolved as you can read HERE
     
    thedesolatesoul likes this.
  3. jcesar

    jcesar Active Member Licensed User

    Thanks for your reply. Problem solved.
     
  4. Dave61

    Dave61 Member Licensed User

    I updated my B4A to 5.0.2 and now I am having this trouble again. I ready through this thread & others and have made multiple copies of zipalign.exe and put them everywhere I can find but I still have the same error.
    Can anyone spot the silly mistake in my setup?
    Thanks
    Dave
     

    Attached Files:

  5. Erel

    Erel Administrator Staff Member Licensed User

    Try to update Android SDK to the latest version.
     
  6. sorex

    sorex Expert Licensed User

    your path is wrong or you copied it to the wrong folder.

    you point to c:\program files\java\sdk while you put the file in c:\program files (x86)\Android\sdk
     
  7. Dave61

    Dave61 Member Licensed User

    So the zipalign.exe needs to have the same root as the android.jar by the looks of it? I hadn't seen that documented anywhere before:
    i.e. both c:\program files\.... above.
    I had already installed the newest JDK a couple of days before, but I did it again and this time put it in C:\Android. So now I have:
    C:\Android\build-tools\22.0.1\zipalign.exe and
    C:\Android\platforms\android-22\android.jar
    and all is working fine.

    Thanks Guys!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice