Android Question Admob error code 0

Discussion in 'Android Questions' started by DarkSmart, Jun 13, 2019.

  1. DarkSmart

    DarkSmart Member Licensed User

    Hi
    I have a significant problem that I have raised several times, but no one answered me correctly and my problem is not resolved
    My problem with not displaying Google admob is that after running the program, and after a minute, I will encounter an error 0 and do not display ads.
    I even tried the test mode, but did not differ and did not work
    I think the problem is not coding and b4a because the codes are exactly the ones I found from the forum and said erel
    Meanwhile I use firebase ads according to the thread below:
    https://www.b4x.com/android/forum/t...tegrated-with-firebase-backend.67710/#content
    I also found the thread below that I think my problem is similar but did not give a full explanation about fixing the problem:
    https://www.b4x.com/android/forum/threads/admob-error-code-0.60094/#content
    In the meantime, I installed all the b4a and sdk files again, but my problem was not resolved
    I just did not install the following files (all google maven installed and my sdk folder size is 12GB):
    sdk1.jpg
    my b4a version is 9.0.1 and java is 8 and sdk is 26.1.1 and api platform is 28
    i tested with api 29 but not work
    I have not used firebase ads before
    Also i tested in 3 device with android version 4,6,9 and not worked but when i install and check other app from google play like this, ads show and worked, so problem from me and not from google server:
    https://play.google.com/store/apps/details?id=haibison.android.admob_test_ids
    Also i atached the my project source folder
    Log:
    I explained everything, so please help, and anyone with the experience can help
    Thankful
     

    Attached Files:

    • 1.zip
      File size:
      9.4 KB
      Views:
      14
    Last edited: Jun 13, 2019
  2. sorex

    sorex Expert Licensed User

    there is nothing wrong with the code. the test banner & test interstitial display just fine.

    maybe there is just no ad for your region?
     
  3. sorex

    sorex Expert Licensed User

    those 3 devices where you tested it on are that real devices or emulators?
     
  4. DarkSmart

    DarkSmart Member Licensed User

    No because (I said) i tested other app and worked in my region and just my app not work
    Also i tested with vpn
    Exactly problem not relating to region and google server

    I tested in 2 emulator and 3 really device
     
  5. DarkSmart

    DarkSmart Member Licensed User

    If you tested my project and good worked, so please tell me what your b4a,sdk,java,api version using???
    And please tell me,you which install pakages from sdk manager???
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    The versions are not really important and are not the cause of this problem.
     
    DarkSmart likes this.
  7. sorex

    sorex Expert Licensed User

    B4A: 8.80
    I will need to check for the rest but as Erel mentioned it's not that important as long as it compiles right it should work I guess.

    Check the unfiltered logs maybe there is something mentioned about connection problems.
     
    DarkSmart likes this.
  8. DarkSmart

    DarkSmart Member Licensed User

    I found this from unfiltered log:

    Please check ,what problem?
     
  9. DarkSmart

    DarkSmart Member Licensed User

    my problem is fixed
    Thankful
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice