Spanish Android 5.1 y StartServiceAt

Discussion in 'Spanish Forum' started by Chelu, Apr 7, 2015.

  1. Chelu

    Chelu Member Licensed User

    Buenas.
    Ayer actualicé mi nexus 5 a Android 5.1 y una de mis aplicaciones ha empezado a no funcionar correctamente.
    He estado mirando un poco por encima mi código y la explicación más lógica que le veo es que con Android 5.1 el tiempo mínimo entre servicios es de 4 segundos.
    Antes, con Android 5.0.1 no tenía ningún problema en llamar a un servicio cada segundo. Ahora parece que aunque lo llame cada segundo solo se arranca cada 4.
    ¿Ha alguien le ha ocurrido algo parecido con Android 5.1?
     
  2. bgsoft

    bgsoft Well-Known Member Licensed User

    Hola

    He tenido problemas con Android 5 en Nexus 4 y 5 en el alta de mensajes Push, y sin embargo en otros modelos de moviles con el mismo S.O. no, asi que ya empezando por ahi creo que existe algún tipo de problema con esos Nexus y Android 5 (Samsung ha tenido que retirar su firmware para S4 por que no iba casi nada).

    Para cosas generales con Android 5, te recomiendo que compiles con al menos B4A v3.82, y tambien que añadas al manifest esto:

    Code:
    SetApplicationAttribute(android:theme, "@android:style/Theme.Holo")
    Se que no tiene que ver con tu servicio, pero si estas trabajando con un Nexus y Android 5, en algún momento te surgirá otro problema que con estas dos cosas las corregirás.

    Saludos:
     
    Chelu likes this.
  3. Chelu

    Chelu Member Licensed User

    La cosa es que con el Android 5.0.1 y el 5.0.2 iba como un guante.
    Pero te haré caso, al menos con el manifiesto. La versión de B4A la actualizaré pronto, pero puede que no este mes.
    Gracias.
     
  4. faber

    faber New Member Licensed User

    Hola, tengo el mismo problema. tiempo de 5 segundos es regular, de un segundo es muy variable. Pa siempre hasta un máximo de 5 secundos
    Los segundos están marcando regularmente hasta la versión 4.4
    Yo Android 5.1.1 en el Samsung I9001. La próxima semana debería probar el programa en Samsung S6
    ¿Ha resuelto el problema?

    Gracias a Google para la traducción
     
  5. Chelu

    Chelu Member Licensed User

    No.
    Y la versión 5.1.2 no lo corrige.
    Aunque es verdad que no he actualizado B4A, aunque sí probé lo del manifiesto y no funciona.
    Saludos.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice