iOS Question App cannot install

Discussion in 'iOS Questions' started by Hypnos, Jan 24, 2015.

  1. Hypnos

    Hypnos Active Member Licensed User

    I got a strange issue today, I keep work on my app, modify the code / build and it work fine before (even submitted to itunesconnect and now waiting for review.

    But don't know why it suddenly have this issue:

    when I build the app and install it on my ipad, I can see the popup to press the button to install, but the app never deliver to the device except I change the package name..

    Anyone know what happen? I have little concern to change the package name because the app already waiting for review.

    I tried to hard restart my ipad but no luck! any idea please?
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Have you tried to uninstall the existing app?

    Are you using a development provision profile?
     
  3. Hypnos

    Hypnos Active Member Licensed User

    yes, I think the app already uninstalled as I can't see it in any page, even using search, it not exist in my iPad. I tried both development or distribution key but same result.

    When I change the package name, it can work again. or I install it on my iphone, work too..

    seems the problem only on my ipad device but I'm really don't know what happened!

    what I'm doing before this issue is add iAD in my apps, modify some code , some testing and submitted to itunesconnect. (switch few times for development/dustribution key ) After this I keep doing some enhancement and suddenly got this issue :(
     
  4. Hypnos

    Hypnos Active Member Licensed User

    I reset and erase all my content on iPad, now I can install my app using the old package name!

    The other crazy thing happened to me today.... 1 of my app have 2702+ download in 1 day show in my itunesconnect and I'm sure it's not true because the $$ in my adsense account don't have any increase! the platform of those download is "Desktop".... Desktop!?

    Just now! my keyboard seems sometime not work!! What happened!!!!!!! :mad::mad::mad::mad::mad::confused::confused::eek::eek::eek:o_Oo_Oo_O
     

    Attached Files:

  5. Hypnos

    Hypnos Active Member Licensed User

    I have the same issue again today while I'm update my app into a new version, and now I'm waiting to restore my ipad....

    seems the issue is related to switching between development and distribution key as I did the very simular steps last time.

    what I'm doing this time:

    1. Change my code and version number
    2. install my app and test (development key)
    3. now I need the ipa so I change to distribution key and install again (now the app not work on my ipad as not using development key)
    4. download the ipa file
    5. delete the not work app on ipad
    6. change to development key and install it again on my ipad
    7. problem ! the app won't deliver to my ipad

    I'm wondering whether the problrm is caused by step5... Anyone know anything I did wrong?
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    What happens after step #3? Are you actually able to install the app on the device?


    There is no reason to install a store ready app on a device as it will never work.
     
  7. Hypnos

    Hypnos Active Member Licensed User

    After step #3, the store app installed on my ipad successfully (I know it can't run). But after step 4-6, the development app can't be install... (nothing happen after I press the "install" button)

    The reason I need step 3 because I need the ipa file for apps store (using distribution key), so I need to build it and during "build release app", the store ready app will install to my device....

    Or it's not the correct way to get the store ready ipa file? Thanks!


    (Now I can install after erase all my content on ipad...)
     
  8. Erel

    Erel Administrator Staff Member Licensed User

    Don't install it next time. Press Cancel in the installation dialog or just press on the home button before you compile the release app.

    I can't reproduce it here. I can install a store app and later install a development app.
     
  9. Luiz Fernando Orlandini

    Luiz Fernando Orlandini Active Member Licensed User

    The same issue happens with me. Hours trying to revert, and just starts work again recovering my ipad
     
  10. Hypnos

    Hypnos Active Member Licensed User

    Oh.... You also installed the store app on you iPad and afterwards got this issue?
    Now I won't install the store app on any of my device...
     
  11. Luiz Fernando Orlandini

    Luiz Fernando Orlandini Active Member Licensed User

    Not yet. I'm in the development and tests phases.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice