Android Question Application Crash with Unable to create service

Hari Haran

Member
Licensed User
Hi all,


I am facing a unique problem , my project was working fine till today morning, then while debugging the application is crashing at the beginning of the start ( even before the start)

Logger connected to: Xiaomi Redmi 6 Pro
--------- beginning of main
Copying updated assets files (14)
--------- beginning of crash
java.lang.RuntimeException: Unable to create service linda.skyhms.in.starter: java.lang.RuntimeException: java.net.SocketException: Connection reset
at android.app.ActivityThread.handleCreateService(ActivityThread.java:3577)
at android.app.ActivityThread.access$1400(ActivityThread.java:200)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1689)
at android.os.Handler.dispatchMessage(Handler.java:106)
at android.os.Looper.loop(Looper.java:201)
at android.app.ActivityThread.main(ActivityThread.java:6806)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:547)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:873)
Caused by: java.lang.RuntimeException: java.net.SocketException: Connection reset
at anywheresoftware.b4a.ShellBA.raiseEvent2(ShellBA.java:175)
at linda.skyhms.in.starter.onCreate(starter.java:48)
at android.app.ActivityThread.handleCreateService(ActivityThread.java:3565)
... 8 more
Caused by: java.net.SocketException: Connection reset
at java.net.SocketInputStream.read(SocketInputStream.java:215)
at java.net.SocketInputStream.read(SocketInputStream.java:144)
at java.io.BufferedInputStream.fill(BufferedInputStream.java:248)
at java.io.BufferedInputStream.read(BufferedInputStream.java:267)
at java.io.DataInputStream.readByte(DataInputStream.java:268)
at anywheresoftware.b4a.shell.Shell.raiseEventImpl(Shell.java:344)
at anywheresoftware.b4a.shell.Shell.raiseEvent(Shell.java:255)
at java.lang.reflect.Method.invoke(Native Method)
at anywheresoftware.b4a.ShellBA.raiseEvent2(ShellBA.java:144)
... 10 more
 

Hari Haran

Member
Licensed User
Hi Erel,

I have tested on both Debug and release
on debug it show on the log
and in release mode it give a crash summary
 

Hari Haran

Member
Licensed User
Hi,

Fixed it, in the process_global of general module there was a mistakenly initiated long to empty string ie (public acctid as long = "") this caused the error ,
but the error which is not related with socket , as the error show in the log.

With regards
Hari haran.C
 
Top