Android Question B4A INSTALLATION PROBLEM

DOM85

Active Member
Licensed User
Hi all,
I bougth B4A and tried to install it on a new computer Under Windows 10 pro.
I followed exactly the installation procedure (2 times !).
During installation of B4A SDK manager, after 95% this warning message appeared "Unable to load file repositories.cfg", and installation did not continue.

Now, when i try to compile a quite empty program, i obtain a compile error that i don't know solve.
Next i list the code and the compilation error message.

If someone could help me, thank you (i tried many hours).
DOM.

====
#Region Activity Attributes
#FullScreen: False
#IncludeTitle: True
#End Region
Sub Process_Globals
End Sub
Sub Globals
End Sub
Sub Activity_Create(FirstTime As Boolean)
Activity.LoadLayout("essai_service")
End Sub
Sub Activity_Resume
End Sub
Sub Activity_Pause (UserClosed As Boolean)
End Sub
================
B4A Version : 8.50
Analyse du code. (0.00s)
Building folders structure. (0.01s)
Compilation du code. (0.02s)
Compilation du code des layouts. (0.00s)
Organiser les bibliothèques. (0.00s)
Génération du fichier R. (0.17s)
Compilation du code Java. Error
javac 1.8.0_201
src\b4a\example\essai_service_display.java:17: error: cannot find symbol
ServiceHelper.StarterHelper.startServiceFromReceiver (context, in, false, BA.class);
^
symbol: method startServiceFromReceiver(Context,Intent,boolean,Class<BA>)
location: class StarterHelper
Note: src\b4a\example\essai_service_display.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
1 error
 
Last edited:

DOM85

Active Member
Licensed User
You can ignore this message.

Based on the compilation message, it seems like B4A was not installed properly. Maybe old files were not overwritten. Uninstall B4A, make sure that the installation folder was deleted and install it again.
Effectively, i have not uninstalled B4A. I am going to do it.
 

DOM85

Active Member
Licensed User
You can ignore this message.

Based on the compilation message, it seems like B4A was not installed properly. Maybe old files were not overwritten. Uninstall B4A, make sure that the installation folder was deleted and install it again.
After uninstall B4A the complete install is now good. Thank you Erel and friends !
 
Top