Android Question B4A v.5.02 high resources Task Manager.

joop

Active Member
Licensed User
Hi,

I think the new B4A v.5.02 IDE takes to much resourches
on mine configuration = NVIDIA GEOFORCE AGP en CPU 2.8 Gig
single core,see the sys-info below.

Pressed characters are apearing very slow , and backspace
characters is impossible without backspacing (deleting) good characters.

Win taskmanager giver 90% resources,this is normal not critical
but with V5 it stays to long on 90%.

With a short program it reacts quicker, a long file
it is worse.

Explicit autocomplete is turned off.

V5 is installed on drive J:
I know the combination graphic card and CPU is rather slow.

Will update 4.30 be updated with the latest bugs so
I don't have to get me a faster system.?

I am using 4.30 again and it works ok,I am pleased with it.

Joop



Sys Info
Index Score = 2.8 computer win 7 prof

------------------------------------------------
Component Details Subscore Base score 2.8

Processor Intel(R) Celeron(R) CPU 2.80GHz 3.5
Memory (RAM) 2.00 GB 4.5
Graphics NVIDIA GeForce 6200 2.8
Gaming graphics 815 MB Total available graphics memory 3.2
Primary hard disk 468GB Free (530GB Total) 5.9
Windows 7 Professional

System
--------------------------------------------------
Total amount of system memory 2.00 GB RAM
System type 32-bit operating system
Number of processor cores 1
64-bit capable Yes
Storage
---------------------------------------------------
Total size of hard disk(s) 932 GB
Disk partition (306 GB Free (401 GB Total)
Media drive (D CD/DVD
Disk partition (J 468 GB Free (530 GB Total)
Graphics
-------------------------------------------------
Display adapter type NVIDIA GeForce 6200
Total available graphics memory 815 MB
Dedicated graphics memory 512 MB
Dedicated system memory 0 MB
Shared system memory 303 MB
Display adapter driver version 9.18.13.774
Primary monitor resolution 1024x768
DirectX version DirectX 9.0 or better
Network
-----------------------------------------------
 

joop

Active Member
Licensed User
Yes version 4.5.51209 nvidia has no option to set hardware accelaration on / or off.
 

ivan.tellez

Active Member
Licensed User
Number of processor cores 1
:eek::eek::eek: I haven't seen single core PCs in years.

Could be a runtimes problem, or maybe your OS needs a reinstallation.

In a PC used to develop software, its always recommended to have a fast PC (you can work faster)

The B4A.exe process it's always between 0% and 1% on CPU usage in my PC.
 

joop

Active Member
Licensed User
Yes,I think your right but 4.3 runs fine , so next thing I will try to
switch off hardware acceleration from WPF by chancing the register.
 

sorex

Expert
Licensed User
the product is nearly the same so I don't see either why it would eat way more resources.

it's not that you upgrade from 3D Studio 1 to LightWave 2015 or something like that ;)

I just did the CPU check overhere aswell. When I start typing with explicit completion disabled it also peaks to 95%.
but it drops to 0-2% when I stop typing. it's OK for me like that.

With explicit on it's the same but the delays are way longer (every second 1 char gets added) and impossible to work like that.

too bad to see that the numbers of people going back to 4.x are increasing daily as a lot of work got into this :(
 

joop

Active Member
Licensed User
"it's not that you upgrade from 3D Studio 1 to LightWave 2015 or something like that " :)

I don't no if V4.3 uses WPF , V5 does which needs more graphic power .
My configuration has an index score of 2.8 with the graphic card that gives this low index.

I think i have a mismatched videocard or something like that.
 

sorex

Expert
Licensed User
I doubt it's the gfx card as the slowdown is on keyboard events. all the rest like the menus, designer etc is running at normal speed here.
 

RandomCoder

Well-Known Member
Licensed User
Sounds like a driver/software issue to me. I recall my first Raspberry Pi was just like this, one character every several seconds. Completely unusable. Turned out to be a compatability issue, I forget the exact cause.
Out of interest, what type of keyboard are you using? Is it wireless, USB or PS/2?
 

sorex

Expert
Licensed User
I always use USB wired keyboards on desktops.

also, why is only B4A sensitive for this then?
 

RandomCoder

Well-Known Member
Licensed User
Maybe a compatability issue with WPF? Are there any other WPF based programs that you could install that might help narrow down the problem?
 

sorex

Expert
Licensed User
just did another test...

using VB2010 Ultimate the typing is instant while the intellisense is more complex and the CPU doesn't go over 45%.
 

sorex

Expert
Licensed User
I guess the only hope for us is that @Erel has some older machine in his seller or on his attic so that he can see it himself that there really is an issue.
 

RandomCoder

Well-Known Member
Licensed User
Just had a quick search and here looks to be a good place to try... http://waf.codeplex.com
Check out the first link which says WAF DotNetPad is a simple and fast code editor. We'll soon see ;)
 

sorex

Expert
Licensed User
that installer checks for .NET 4.5 but as this is XP there ain't such thing.
 
Top