Other B4i v2.0 BETA has been released

Discussion in 'iOS Questions' started by Erel, Jul 1, 2015.

  1. Erel

    Erel Administrator Staff Member Licensed User

    [​IMG]

    I'm happy to release the first beta version of B4i v2.00. This is a major update with many important improvements.
    B4i is now based on the new IDE with the same advanced features as B4A v5.0 and B4J v3.0: http://www.b4x.com/android/forum/threads/b4a-v5-00-has-been-released.54653/

    Other improvements:

    Requirements


    - Microsoft .Net Framework 4.0+ is required. If you are running Windows XP then you should install .Net Framework 4.0: https://www.microsoft.com/en-us/download/details.aspx?id=17851

    - Developers running Vista or above should install .Net Framework 4.5.2: https://www.microsoft.com/en-us/download/details.aspx?id=42642

    - Developers using a local builder should update the builder to v2.0 and use Xcode 6.3+.

    Users who are eligible for a free upgrade should receive an email with the download links.

    This is a beta version. Make sure to backup your projects before loading them in the new version.
    You can install B4i v2.0 in a different folder and keep both versions.

    Thank you for your help with the development of B4X tools :)

    V2.00 beta 3: http://www.b4x.com/android/forum/threads/b4i-v2-0-beta-has-been-released.55712/page-2#post-350922
     
    Last edited: Jul 2, 2015
    imbault, barx, MikeH and 3 others like this.
  2. le_toubib

    le_toubib Active Member Licensed User

    1-When u select a word, in the IDE , how to search for it (no goggles icon)

    2-Also, I have a hosted builder account, but I also have a Mac device without the local builder. How can I use the simulator without the local builder on the Mac device.

    3- multiline in picker is supported now?

    Thanks
     
  3. ivanomonti

    ivanomonti Well-Known Member Licensed User

    wow, the best 10000000000000000000000000000, simulator ios
     
  4. stephane

    stephane Member Licensed User

    Hello,
    I have installed the latest version of B4i (2.00) then I saw this error when I tried to start the software.
    Could you explain why and how I can solve this issue.

    upload_2015-7-1_12-55-51.png
     
  5. Haris Hafeez

    Haris Hafeez Active Member Licensed User

    This looks very good but I've already got an issue while installing this. The following popup gets presented when I run B4i.
    EDIT: I also get the error in post 4 above.
    upload_2015-7-1_11-58-16.png
     
  6. Pendrush

    Pendrush Active Member Licensed User

    Same here
     
  7. klaus

    klaus Expert Licensed User

    Same for me, I get both messages like post #4 and 5 .
     
  8. narek adonts

    narek adonts Well-Known Member Licensed User

  9. Erel

    Erel Administrator Staff Member Licensed User

    I've uploaded v2.00 Beta 2. It fixes the license issue.

    1. Press ctrl + F or Edit - Quick Search.
    2. You will need to run the local builder. You can use both the hosted builder and the local builder.
    3. No. Other features not mentioned in the first post were not implemented.
     
  10. sorex

    sorex Expert Licensed User

    how many hours does your spam tool need to send out all mails?
     
  11. Erel

    Erel Administrator Staff Member Licensed User

    All mails were sent. Contact support@basic4ppc.com if you didn't receive it (make sure to check the spam folder).
     
  12. Erel

    Erel Administrator Staff Member Licensed User

    If you are familiar with B4A v5.0 then this version includes some small features that are not available yet in B4A:

    - You can change the logs font under Tools - IDE Options - Font Picker (change the target).
    - You can open the designer directly from the files tab:

    [​IMG]

    - New colors list in the designer:

    [​IMG]
     
    MikeH and Pendrush like this.
  13. omidaghakhani1368

    omidaghakhani1368 Well-Known Member Licensed User

    Hi.
    Good luck.With iOS simulator we dont need to device.
    Please add menu to explorer my project for open directory
     
  14. Erel

    Erel Administrator Staff Member Licensed User

    You can open explorer from the Files tab (right click on the files list).
     
  15. tufanv

    tufanv Well-Known Member Licensed User

    Thank you Erel ! I hope now i can search within the designer =)
     
  16. Pendrush

    Pendrush Active Member Licensed User

    Tested few apps in Simulator, everything work as expected, also app have same speed (very fast) as on real device.
     
    Erel and Peter Simpson like this.
  17. ilan

    ilan Expert Licensed User

    Is it possible to move in the abstract designer without the taskbar?

    Like holding down the CRTL button or middle mouse button.

    I have big layouts and i need to move inside a lot and with the taskbar its not comfortable...
     
  18. Erel

    Erel Administrator Staff Member Licensed User

    Yes. Press on Shift + one of the arrows. Note that you can also zoom in and out with the mouse wheel.
     
    Peter Simpson likes this.
  19. Rafael Ruiz

    Rafael Ruiz Member Licensed User

    Hi.

    I have xcode and local builder installed. Can you explain how to use the simulator? I have this message when i tried to Run the code: "Sending data to remote compiler. Error"

    Thanks in advance.
     
  20. Erel

    Erel Administrator Staff Member Licensed User

    @Rafael Ruiz Please start a new thread for this. It will be easier to discuss and solve.
     
    Last edited: Jul 1, 2015
Loading...