Other B4i v2.0 BETA has been released

Erel

Administrator
Staff member
Licensed User


I'm happy to release the first beta version of B4i v2.00. This is a major update with many important improvements.
B4i is now based on the new IDE with the same advanced features as B4A v5.0 and B4J v3.0: http://www.b4x.com/android/forum/threads/b4a-v5-00-has-been-released.54653/

Other improvements:

Requirements


- Microsoft .Net Framework 4.0+ is required. If you are running Windows XP then you should install .Net Framework 4.0: https://www.microsoft.com/en-us/download/details.aspx?id=17851

- Developers running Vista or above should install .Net Framework 4.5.2: https://www.microsoft.com/en-us/download/details.aspx?id=42642

- Developers using a local builder should update the builder to v2.0 and use Xcode 6.3+.

Users who are eligible for a free upgrade should receive an email with the download links.

This is a beta version. Make sure to backup your projects before loading them in the new version.
You can install B4i v2.0 in a different folder and keep both versions.

Thank you for your help with the development of B4X tools :)

V2.00 beta 3: http://www.b4x.com/android/forum/threads/b4i-v2-0-beta-has-been-released.55712/page-2#post-350922
 
Last edited:

le_toubib

Active Member
Licensed User
1-When u select a word, in the IDE , how to search for it (no goggles icon)

2-Also, I have a hosted builder account, but I also have a Mac device without the local builder. How can I use the simulator without the local builder on the Mac device.

3- multiline in picker is supported now?

Thanks
 

stephane

Member
Licensed User
Hello,
I have installed the latest version of B4i (2.00) then I saw this error when I tried to start the software.
Could you explain why and how I can solve this issue.

upload_2015-7-1_12-55-51.png
 

Haris Hafeez

Active Member
Licensed User
This looks very good but I've already got an issue while installing this. The following popup gets presented when I run B4i.
EDIT: I also get the error in post 4 above.
upload_2015-7-1_11-58-16.png
 

Erel

Administrator
Staff member
Licensed User
I've uploaded v2.00 Beta 2. It fixes the license issue.

1-When u select a word, in the IDE , how to search for it (no goggles icon)

2-Also, I have a hosted builder account, but I also have a Mac device without the local builder. How can I use the simulator without the local builder on the Mac device.

3- multiline in picker is supported now?
1. Press ctrl + F or Edit - Quick Search.
2. You will need to run the local builder. You can use both the hosted builder and the local builder.
3. No. Other features not mentioned in the first post were not implemented.
 

Erel

Administrator
Staff member
Licensed User
If you are familiar with B4A v5.0 then this version includes some small features that are not available yet in B4A:

- You can change the logs font under Tools - IDE Options - Font Picker (change the target).
- You can open the designer directly from the files tab:



- New colors list in the designer:

 

omidaghakhani1368

Well-Known Member
Licensed User
Hi.
Good luck.With iOS simulator we dont need to device.
Please add menu to explorer my project for open directory
 

ilan

Expert
Licensed User
Is it possible to move in the abstract designer without the taskbar?

Like holding down the CRTL button or middle mouse button.

I have big layouts and i need to move inside a lot and with the taskbar its not comfortable...
 

Erel

Administrator
Staff member
Licensed User
Yes. Press on Shift + one of the arrows. Note that you can also zoom in and out with the mouse wheel.
 

Rafael Ruiz

Member
Licensed User
Hi.

I have xcode and local builder installed. Can you explain how to use the simulator? I have this message when i tried to Run the code: "Sending data to remote compiler. Error"

Thanks in advance.
 

Erel

Administrator
Staff member
Licensed User
@Rafael Ruiz Please start a new thread for this. It will be easier to discuss and solve.
 
Last edited:
Top