Other B4i v2.0 BETA has been released

Erel

Administrator
Staff member
Licensed User
SS-2015-07-01_12.46.01.png


I'm happy to release the first beta version of B4i v2.00. This is a major update with many important improvements.
B4i is now based on the new IDE with the same advanced features as B4A v5.0 and B4J v3.0: https://www.b4x.com/android/forum/threads/b4a-v5-00-has-been-released.54653/

Other improvements:

Requirements


- Microsoft .Net Framework 4.0+ is required. If you are running Windows XP then you should install .Net Framework 4.0: https://www.microsoft.com/en-us/download/details.aspx?id=17851

- Developers running Vista or above should install .Net Framework 4.5.2: https://www.microsoft.com/en-us/download/details.aspx?id=42642

- Developers using a local builder should update the builder to v2.0 and use Xcode 6.3+.

Users who are eligible for a free upgrade should receive an email with the download links.

This is a beta version. Make sure to backup your projects before loading them in the new version.
You can install B4i v2.0 in a different folder and keep both versions.

Thank you for your help with the development of B4X tools :)

V2.00 beta 3: https://www.b4x.com/android/forum/threads/b4i-v2-0-beta-has-been-released.55712/page-2#post-350922
 
Last edited:

ShaneG30

Well-Known Member
Licensed User
With iOS simulator we dont need to device.

Actually, it's recommended to always test on a real device due to the differences in the CPU architecture. The simulator uses your Mac's CPU while iOS devices use ARM CPUs. This difference can cause bugs only on the simulator and not on the device or vice versa.
 
Upvote 0

moster67

Expert
Licensed User
  1. Do you know if it safe to update to xcode7 and if it will work with the new version of B4i and the new ios simulator feature?
  2. Using xcode7, it seems like some earlier requirements such as having a paid apple developer account is not further needed for testing apps on your real device. You still however need the apple developer account if you want to publish your apps on Apple Store. Will this work fine with B4i too?

Here you can find more information:
https://developer.apple.com/xcode/

I could test myself but I thought you may have have already checked out this since you are probably a step ahead of us others making sure B4i will work fine with future Xcode-versions and new requirements. Thanks.
 
Upvote 0

moster67

Expert
Licensed User
Here is my windows desktop with b4i in forefront and next to it Teamviewer showing the ios-simulator running on my Mac Mini. I need to do this since I have only one monitor to which both my PC and Mac are connected but this solution works great.

I am so happy now :)

b4iwithSimulator.PNG
 
Upvote 0

tucano2000

Active Member
Licensed User
Much better. Now with the simulator I can see the layout in all iphone and ipad. Another improvement you made and was also very helpful for me was the scrooll for the layout. Congratulations Erel . It's a wonderful job.
 
Upvote 0

Haris Hafeez

Active Member
Licensed User
I'm getting an issue while trying to load a designer layout file. This project was created in the current release version of b4i(1.8 I believe).

Please find the project attached and also the screenshot. The layout file causing the issue is named 1. The other layout file in the project is working fine.

1.png
 

Attachments

  • ActivityIndicator.zip
    6.9 KB · Views: 186
Upvote 0

ShaneG30

Well-Known Member
Licensed User
Sorry, but where can I download the new version of B4i 2.00?

Thank you.

Check your email. Purchasers of B4i should receive a link in their email during their free upgrade period.
 
Upvote 0

tufanv

Expert
Licensed User
Erel,

in des,gner , right clicking on a view sometimes not opens cut , copy,paste dialog view.
IS it a bug ?=
 
Upvote 0

tufanv

Expert
Licensed User
Erel

I am seeing this IDE for the first time as my b4a upgrade has ended and i couldnt buy it yet. It is perfect. I am feeling better while coding =) Thank you !
 
Upvote 0
Top