B4J Question B4JPackager11 question

Discussion in 'B4J Questions' started by lledden, Apr 25, 2019.

  1. lledden

    lledden Member Licensed User

    This is my first-time user of the packager. Installed java jdk11 and InnoSetup. The packager runs and appears to be successful but the log shows 'InputJar not set' even through it is set in line 8. The resulting B4JPackager11.jar file gives the error 'A JNI error has occurred...' message and aborts. Included a screen shot showing the relevant values. Any suggestions would be appreciated.
     

    Attached Files:

    Last edited: Apr 25, 2019
  2. Erel

    Erel Administrator Staff Member Licensed User

    It is always better to post the logs and code as text. Right click to copy from the logs.

    What is line 8?
    In the code you posted InputJar is not set. Remove the apostrophe character.
     
  3. lledden

    lledden Member Licensed User

    Thanks Erel for the quick response.... that was a careless edit on my part... Fixed that, cleaned the project and all is working.
     
  4. lledden

    lledden Member Licensed User

    A followup question. The first project worked fine; built an installation with Setup Factory, installed it and it ran fine on a clean machine. My second project however, doesn't work at all. Ran the packager which completed ok. Attempted to execute the Run.exe file in the build folder and it crashed windows 10 with a 'security error' message. Didn't get the exact wording. I'm running Win10 pro insider preview build 18865...
     
  5. lledden

    lledden Member Licensed User

    any suggestions of how to investigate and resolve this would be greatly appreciated
     
  6. OliverA

    OliverA Expert Licensed User

    We thrive on exact wording
     
  7. lledden

    lledden Member Licensed User

    The error is 'Kernel Security Check Failure'. I copied the same install to a production version of Windows (version 1809, build 17763...), and it works ok... so I guess this is just an insider build issue and can be 'ignored' for now. Kind of weird that the first project worked fine and this one has a fatal crash.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice