B4J Question B4JPackager11 question

lledden

Member
Licensed User
This is my first-time user of the packager. Installed java jdk11 and InnoSetup. The packager runs and appears to be successful but the log shows 'InputJar not set' even through it is set in line 8. The resulting B4JPackager11.jar file gives the error 'A JNI error has occurred...' message and aborts. Included a screen shot showing the relevant values. Any suggestions would be appreciated.
 

Attachments

Last edited:

Erel

Administrator
Staff member
Licensed User
It is always better to post the logs and code as text. Right click to copy from the logs.

What is line 8?
In the code you posted InputJar is not set. Remove the apostrophe character.
 

lledden

Member
Licensed User
Thanks Erel for the quick response.... that was a careless edit on my part... Fixed that, cleaned the project and all is working.
 

lledden

Member
Licensed User
A followup question. The first project worked fine; built an installation with Setup Factory, installed it and it ran fine on a clean machine. My second project however, doesn't work at all. Ran the packager which completed ok. Attempted to execute the Run.exe file in the build folder and it crashed windows 10 with a 'security error' message. Didn't get the exact wording. I'm running Win10 pro insider preview build 18865...
 

lledden

Member
Licensed User
The error is 'Kernel Security Check Failure'. I copied the same install to a production version of Windows (version 1809, build 17763...), and it works ok... so I guess this is just an insider build issue and can be 'ignored' for now. Kind of weird that the first project worked fine and this one has a fatal crash.
 
Top