B4J Question B4jPackager11 unable to pack B4xLocalizator

Discussion in 'B4J Questions' started by janderkan, Jul 28, 2019.

  1. janderkan

    janderkan Active Member Licensed User

    I use the latest versions of Erel's programs.

    Run B4xLocalizator from B4J and it reads the XML file and create the .DB file.

    Pack B4xLocalizator with B4jPackager11 and the .DB file is empty.

    Attached is the output from command window and the xmlbeandebug file
     

    Attached Files:

  2. Erel

    Erel Administrator Staff Member Licensed User

  3. janderkan

    janderkan Active Member Licensed User

    In the link you show this json file:
    Code:
    {
       InputJar: 
    "C:/Users/H/Downloads/projects/jpoitest/Objects/main.jar",
       IncludedModules: [
    "jdk.charsets"],
       AdditionalModuleInfoString: 
    "opens schemaorg_apache_xmlbeans.system.sD023D6490046BA0250A839A9AD24C443;"
    }
    On my system this is the correct file:
    Code:
    {
       InputJar: 
    "C:/2Work/1C/B4J/B4XLocalizator/Objects/B4XLocalizator.jar",
       IncludedModules: [
    "jdk.charsets"],
       AdditionalModuleInfoString: 
    "opens schemaorg_apache_xmlbeans.system.sF1327CCA741569E70F9CA8C9AF9B44B2;"
    }
    As you can see it uses another xmlbeans.system.number

    I found the correct number this way:
    1.
    Add jar file to B4JPackager11 code and run.
    2.
    Run the created run_debug.bat
    3.
    In the command window you can see where to find the 'Diagnostic XML Bean debug log file'
    4.
    In the first line of the debug file you find the correct number for your 'AdditionalModuleInfoString'
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice