Wish [B4X] Turn off Auto indent on paste.

MrKim

Well-Known Member
Licensed User
I like the auto indent feature, But definitely NOT when pasting.

1. It frequently doesn't match MY indent location.
2. If you pasting a small piece of text into a line (ie changing a view name) it not only changes the indent, but the cursor jumps to the end of the line.
3. If you are pasting a full line or more, if it doesn't like where you have your indents it changes not only the line you are on but the ones above and below.
 

klaus

Expert
Licensed User
Have you tried to uncheck this option ?

1620467656730.png
 

MrKim

Well-Known Member
Licensed User
Have you tried to uncheck this option ?

View attachment 113023
I am in B4A 10.7 and do not have that option. If t is new then that alone is worth stopping what I am doing and updating!

Edit: So sad. I had to look again. I haven't changed these settings in so long - seemed like some things were missing.
What was missing was me seeing the > arrow next to ide options.
Thank you.
PS.
What is really sad is how long I have been wrestling with this not realizing we had that option.
 
Last edited:
Top