Android Question Both Emulator & Bridge cannot be properly utilized [Solved but no bridge]

Shelby

Well-Known Member
Licensed User
A few weeks ago a couple of us and perhaps more members, had problems suddenly with the B4A emulator displaying correctly. Today, I hadn't run my program in perhaps a month due to our family moving to a new city. When I started the tools>run AVD manager, I saw that 11 google maven files needed to be installed, so I did that and as usual my emulator didn't display correctly so I decided to run the B4A bridge instead. The bridge had been pretty stable as far as giving a correct display. Unfortunately, I got the error saying:

Ping failed (IP = 192....my phone's IP address):
The IP address is most probably incorrect.
Do you want to use it?

Consequently, I said yes, no success;
Then I said no, no success;
Then I reentered my same IP address as new, and no success.

Perhaps the new 11 files in the AVD manager have caused a problem for me?
Hopefully, someone here can help with my situation.
Thanks
P.S. I have a new internet provider with a new modem. I'm not sure if that new configuration might have some bearing on my bridge not recognizing my phone.
P.P.S. Any chance B4A Bridge can become corrupted? I'll try to install a new B4A bridge onto my phone. Afterward: that didn't work.
 
Last edited:

Peter Simpson

Expert
Licensed User
Longtime User
A few weeks ago a couple of us and perhaps more members, had problems suddenly with the B4A emulator displaying correctly.

Have you tried turning off your new router fire wall (temporarily) and also your development machines firewall (temporarily) just to see if B4A will connect to the B4A-Bridge on your phone???
 
Upvote 0

Shelby

Well-Known Member
Licensed User
I can try that. Thanks
I turned off the windows firewall and no improvement. I'm not sure how to turn off a modem firewall. You see I don't have a router since my Cox Cable Company (only ISP available) furnishes a modem taking the place of a router.
 
Last edited:
Upvote 0

Shelby

Well-Known Member
Licensed User
Well, 192.168.1.65 is what the IDE shows; as it has forever. (That is verified by my purchase details. So no problem there apparently.)

The phone shows:
My IP: Not connected to
Satus: (*)
Waiting for connections
Start
...................
Stop
Thanks
 
Last edited:
Upvote 0

Shelby

Well-Known Member
Licensed User
Hmm,
We have At&t cell phone service. Now that we have moved, Cox cable has given us a cable modem for the internet. I just don't know how to access or make choices with my modem.
I have noticed other members talking of debugging with USB cable so perhaps that's my answer.
O.K., I've just put my charging cord into my HP PC and into my phone (Samsung S9). Now I'll bring up my B4A program. B4A bridge doesn't work so I'll stumble around looking for threads here on "debug mode via usb cable". I have no familiarity with hot spots, etc.. In my control panel I see Directv Mediashare Renderer and I have no idea how to use it. My Galaxy S9 is now in the control panel devices section as well.
Voila! All seems to be working now using the USB debugging. I don't even have to use the tools icon to choose the bridge or the emulator. I just run an app and it displays on my phone.
Thanks again for the suggestions Peter.

The bridge seems to be useless now.
 
Last edited:
Upvote 0

udg

Expert
Licensed User
Longtime User
Hi, I'm glad to see you solved your problem.
Anyway, a few considerations may help you further. Your cable company set up a kind of "black box" in your house. Try to figure out the maker/model in order to search the Internet for configuration details. In case the box has no provision for a wi-fi, you could cascade a second appliance to the first one (use one of the LAN ports) and have this second device establish a wi-fi for your family. This will be the point where B4A-Bridge and your phones will link to when home.

I doubt the cable compnay device isn't able to set up a wi-fi , so the problem could just be to figure out what are the admin credentials needed to access the config pages.
There are companies that, to ease the installation at the customer's home, mail modems pre-configured (that's ok) but fail to comunicate admin credentials (that's bad).

udg
 
Upvote 0

Shelby

Well-Known Member
Licensed User
I had hoped for just that scenario. Thanks for verifying my intuition. At one point I tried to enter the IP Address for such a connection; so I'll keep trying.
Shelby
 
Upvote 0
Top