Android Question [CLOSED] Code not updated

Discussion in 'Android Questions' started by lemonisdead, Jun 22, 2015.

  1. lemonisdead

    lemonisdead Well-Known Member Licensed User

    Hello,

    In wich conditions could a code not being updated inside the generated apk, please ?

    I am referring to that thread and noticed that my code is referring to a service not still used. I have checked my code.

    Many thanks
     
  2. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    check if you are using intents in the manifest file that refer to a service that may not be used anymore.
     
    lemonisdead likes this.
  3. lemonisdead

    lemonisdead Well-Known Member Licensed User

    Of course I did. And there is nothing like that. My code, in the services, seems not to be updated that's all.

    I have :
    - deactivated any other antivirus than Windows Defender
    - deactivated any process manager (software to boost the processes)
    - rebooted the computer
    - uninstalled the app on the phone, rebooted the phone
    - updated the app's version name to be able to check if the apk installed is the one generated (I had the same problem in the past because of an antivirus) : the version's name is updated

    Really I don't understand. That's crazy

    Now I will create a new project and copy/paste the code in its modules
     
  4. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    Very strange !
     
    lemonisdead likes this.
  5. Erel

    Erel Administrator Staff Member Licensed User

    The only thing that I can think of is that maybe some of generated Java code files are read-only. Delete all the objects folder (except of the res folder) and see what happens.
     
    Jmu5667 and lemonisdead like this.
  6. sorex

    sorex Expert Licensed User

    I have that sometimes when dropbox starts sync'ing during compile but then B4A reports an error that it can't access certain file.
     
    lemonisdead likes this.
  7. lemonisdead

    lemonisdead Well-Known Member Licensed User

    Hello,
    I do thank you all for your help. Copying/Pasting the code into a new project fixed my issue at first.

    And Erel was right : there was something with the objects folder. Deleting it in the old Project fixed the issue for that project. I do thank you all again for your support
     
    Jmu5667, RandomCoder and DonManfred like this.
  8. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    Cool, erel is always right :)
     
    lemonisdead likes this.
  9. tigrot

    tigrot Well-Known Member Licensed User

    Erel is a master!
     
Loading...