Compiling Problems - Images must not include spaces

Discussion in 'Bug Reports' started by J12345T, May 31, 2008.

  1. J12345T

    J12345T Member Licensed User

    Hi All,

    I'm trying to compile my program using the optimised compile. I have CF Net 2.0 installed but an error occurs:-

    error CS2001: Source file 'icon.bmp' could not be found.

    Although I have some 800 lines of code and 4 forms I don't think it ever calls for a file 'icon.bmp'. Just in case I added a picture and called it icon.bmp into the same directory however still no joy. Any ideas would be appreciated.

    P.S. I have compiled an earlier version of the program using the legacy compiler with no probs and the program runs fine within B4PPC.

    :sign0085:
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    It is probably some image you've added with the visual designer.
    If you don't find it please upload your source code.
     
  3. J12345T

    J12345T Member Licensed User

    Thanks Erel,

    I'll try to upload the file as I really can't see where it is calling for icon.bmp. It's probably something simple but I just can't see it. It obviously won't run without all the other files. Let me know if you need them also.

    P.S. I apologise in advance for what is probably very messy code. I am a beginner.

    Thanks,

    JT
     

    Attached Files:

  4. klaus

    klaus Expert Licensed User

    To be able to test your program you should also join the bitmaps you are using, because the program is looking for those first. So it's nor easy to check the behaviour. Otherwise we must first look what bitmap is missing, add some dummy bitmaps and so on.

    Best regards.
     
  5. J12345T

    J12345T Member Licensed User

    :sign0161:

    OK I tried that but it maxed out the upload limit after the first bmp. There are 22 bmp's, 3 tables and a number of txt files so I guess it's not really practical. The entire folder is 2.5mb. Maybe I could email it?

    Thanks again for your help.

    JT
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    This is a bug.
    Embedded image names must not include spaces.
    It will be fixed in the next release.
     
  7. J12345T

    J12345T Member Licensed User

    Thanks again Erel that fixed that problem. Next error is:-

    CS1525 invalid expression term ')'
    Table1.loadcsv("table1.csv",",",true)

    Sorry again...

    JT
     
  8. dennishea

    dennishea Active Member Licensed User

    Hi J12345T.

    I don't this is right.

    Table1.loadcsv("table1.csv",",",true)

    I think this is, the true's false wording depends on how you have your headers and col's set up.

    Table1.LoadCSV ("table1.csv", ",", True, True)

    :)
     
  9. J12345T

    J12345T Member Licensed User

    Thanks.

    You are correct however it seemed to work fine with the legacy compiler... I've corrected the error however I'm now getting other errors. I guess my code is just sloppy although not intentionally so; I'm just a beginner at all of this.

    Cheers,

    JT
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice