Android Question Crashlytics/InAppReview problem

Jack Cole

Well-Known Member
Licensed User
I am trying to get crashlytics to work. I have a stripped down project with only Crashlytics and InAppReview libraries. I am getting the following error:

B4X:
Compiling generated Java code.    (1.34s)
Convert byte code - optimized dex.    Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/DataEncoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/Encoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/EncodingException;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ObjectEncoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ObjectEncoderContext;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ValueEncoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ValueEncoderContext;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/annotations/Encodable;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/annotations/Encodable$Field;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
    at com.android.dx.command.dexer.Main.processAllFiles(Main.java:692)
    at com.android.dx.command.dexer.Main.runMonoDex(Main.java:315)
    at com.android.dx.command.dexer.Main.runDx(Main.java:293)
    at com.android.dx.command.dexer.Main.main(Main.java:249)
    at com.android.dx.command.Main.main(Main.java:94)
Caused by: java.lang.InterruptedException: Too many errors
    at com.android.dx.command.dexer.Main.processAllFiles(Main.java:684)
    ... 4 more

This is all I have for the libraries to start.
1614027848166.png


Starting over with a clean SDK / resources folder, I get a series of errors requiring installation of additional resources from the SDK manager.

Adding the InAppReview library, I get the following:
1614030435249.png


After installing that, I get the following in the stripped down crashlytics only test app:

1614028886464.png


So, I install the 16.1.0 firebase-encoders package. After doing so and attempting to compile, I get the original message referenced at the start of this post.

Any ideas?
 

Jack Cole

Well-Known Member
Licensed User
I'm getting the same problem after upgrading to the new beta.

Compiling generated Java code. (7.05s)
Convert byte code - optimized dex. Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/DataEncoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/Encoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/EncodingException;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ObjectEncoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ObjectEncoderContext;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ValueEncoder;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/ValueEncoderContext;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/annotations/Encodable;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/firebase/encoders/annotations/Encodable$Field;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
at com.android.dx.command.dexer.Main.processAllFiles(Main.java:692)
at com.android.dx.command.dexer.Main.runMultiDex(Main.java:366)
at com.android.dx.command.dexer.Main.runDx(Main.java:291)
at com.android.dx.command.dexer.Main.main(Main.java:249)
at com.android.dx.command.Main.main(Main.java:94)
Caused by: java.lang.InterruptedException: Too many errors
at com.android.dx.command.dexer.Main.processAllFiles(Main.java:684)
... 4 more
 
Upvote 0

Jack Cole

Well-Known Member
Licensed User
Another detail. Trying to get just crashlytics working alone.

I started with a fresh Android SDK directory. Installed only firebase-encoders. Then I get the same error.

Here are the only libraries selected for the project.

1614864500212.png
 
Upvote 0

Almora

Active Member
Licensed User
I had seen the same error when installing b4a on a new pc.
Delete or backup the android folder. because the size is too big and you don't have to download it again.
I only "required resources" "command line tool" installed.
Do not download the recommended mavens.
Try it this way. I guess there will be a solution.
 
Upvote 0
Top