Android Question Emulator Problem

wdegler

Active Member
Licensed User
Longtime User
I have been away from B4A programming for a while, but after I installed version 3.80 of B4A, I decided to run my previously published B4A apps on the B4A emulator. When I click on "Tools", and then on "Run AVD Manager", there is a screen which flashes on and immediately off again and the AVD screen does not appear, even after a long wait. It worked earlier, when I was developing the apps.

I know the emulator is slow, but for some things, it is handier for me than connecting a device and running the B4A bridge.

I would appreciate any advice about how to fix this problem.
 

wdegler

Active Member
Licensed User
Longtime User
Bypass the default AVD.
google GenyMotion ... much faster
Thanks for the suggestion, Mangojack.
I have downloaded and installed GenyMotion as you suggested. When I start it, I see "Virtualization Engine not found" in the bottom part of its startup screen. How do I use this program? (compiling doesn't find it and the AVD Manager button doesn't get it).
 
Upvote 0

mangojack

Well-Known Member
Licensed User
Longtime User
1. Confirm your PC Bios setting (advanced) 'Intel Virtualization Technology' or similar is Enabled .

if still error .. machine type / OS ?

You should start GenyMotion then 'Play' your VD prior to debugging/compiling project. then it will be found.
You can start VirtualBox and edit your VD's from there.
 
Upvote 0

wdegler

Active Member
Licensed User
Longtime User
1. Confirm your PC Bios setting (advanced) 'Intel Virtualization Technology' or similar is Enabled .

if still error .. machine type / OS ?

You should start GenyMotion then 'Play' your VD prior to debugging/compiling project. then it will be found.
You can start VirtualBox and edit your VD's from there.
Thanks for the suggestions.
I am not sure how to check the "Intel Virtualization Technology" setting but I am sure I did not change it since the time the default AVD did work.
This computer is a Gateway 64-bit laptop with Microsoft Windows 7.
I will try starting GenyMotion first later and see whether that works.
 
Upvote 0

wdegler

Active Member
Licensed User
Longtime User
Thanks for the suggestions.
I am not sure how to check the "Intel Virtualization Technology" setting but I am sure I did not change it since the time the default AVD did work.
This computer is a Gateway 64-bit laptop with Microsoft Windows 7.
I will try starting GenyMotion first later and see whether that works.
GenyMotion still does not work for me. It displays the following message:
"Unable to load VirtualBox engine.".
The error window is attached. Any further help about how to enable it will be appreciated.
 

Attachments

  • VirtualBox error.jpg
    VirtualBox error.jpg
    54 KB · Views: 118
Upvote 0

mangojack

Well-Known Member
Licensed User
Longtime User
1. I could be completely wrong here , but I seem to recall that although I initially used the default AVD the BIOS setting for "Intel Virtualization" was Disabled .... and on installing GenyMotion it was Enabled. (I seem to recall Enabling it for some reason).

You should at least confirm this setting is Enabled .. as it is one of the prime reasons for this message.
On machine start up you should see a brief message .. to enter settings press (DEL) or (F2) or some other key .. this will allow you access to you machines BIOS. (just take care if you have not accessed before) .. there should be instructions what key to press to save changes.

2. Have you confirmed on the GenyMotion site your machine specs are OK .. (OpenGL ?) and read troubleshooting guide.

3 Can You start Oracle VM Virtual Box and see your downloaded GenyMotion device /s

4. Completely uninstall / reinstall Oracle Virtaul Box and GenyMotion.

5. See if have better luck with "BlueStacks Emulator"

6.Post fresh thread requesting help to get default AVD working..:(

Best of luck.
 
Upvote 0

wdegler

Active Member
Licensed User
Longtime User
1. I could be completely wrong here , but I seem to recall that although I initially used the default AVD the BIOS setting for "Intel Virtualization" was Disabled .... and on installing GenyMotion it was Enabled. (I seem to recall Enabling it for some reason).

You should at least confirm this setting is Enabled .. as it is one of the prime reasons for this message.
On machine start up you should see a brief message .. to enter settings press (DEL) or (F2) or some other key .. this will allow you access to you machines BIOS. (just take care if you have not accessed before) .. there should be instructions what key to press to save changes.

2. Have you confirmed on the GenyMotion site your machine specs are OK .. (OpenGL ?) and read troubleshooting guide.

3 Can You start Oracle VM Virtual Box and see your downloaded GenyMotion device /s

4. Completely uninstall / reinstall Oracle Virtaul Box and GenyMotion.

5. See if have better luck with "BlueStacks Emulator"

6.Post fresh thread requesting help to get default AVD working..:(

Best of luck.
I very much appreciate this attention you are giving to my problem. I intend to follow your suggestions. What I know so far:
1. I get to the BIOS pressing F2 at the right time; nothing in its menu seems to relate to "Virtualization engine", "Virtual Box" or anything else virtual.
2. I installed GenyMotion on another computer (an older Windows XP system) with exactly the same message generated: same results.
3. I tried installing "Bluestacks emulator" and received the message "... not compatible with BitDefender", which I use.
4. The older (Windows XP) computer does work with the default AVD.

I expect to use it then until the mystery with my newer computer is solved. Thanks for your help; I feel much ahead of where I was with your help!
 
Upvote 0
Top