iOS Question Error: ** BUILD FAILED ** - when trying to compile exact same code that worked 2 days ago


Well-Known Member
Licensed User
Longtime User
I am way out of my depth with this:
B4i Version: 8.00
Parsing code. (0.24s)
Building folders structure. (0.00s)
Compiling code. (0.17s)
Compiling layouts code. (0.01s)
Building Xcode project. (0.16s)
Preparing project for builder. (1.55s)
Project size: 0.85 MB
Sending data to remote compiler. Error
Out: Command line invocation:
/Applications/ -configuration Release PRODUCT_NAME=Customer CONFIGURATION_BUILD_DIR=/Users/administrator/Documents/UploadedProjects/<user id>/Payload "CODE_SIGN_IDENTITY=iPhone Distribution: Jack Kirkpatrick (543D8UN4C6)" "OTHER_CODE_SIGN_FLAGS=--keychain <user id>" PROVISIONING_PROFILE=4f616926-d584-4a4f-b6d0-18beb8c0b777 -arch armv7 -arch arm64

User defaults from command line:
IDEPackageSupportUseBuiltinSCM = YES

Build settings from command line:
ARCHS = armv7 arm64
CODE_SIGN_IDENTITY = iPhone Distribution: Jack Kirkpatrick (543D8UN4C6)
CONFIGURATION_BUILD_DIR = /Users/administrator/Documents/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PROVISIONING_PROFILE = 4f616926-d584-4a4f-b6d0-18beb8c0b777

note: Using codesigning identity override: iPhone Distribution: Jack Kirkpatrick (543D8UN4C6)
Computing target dependency graph and provisioning inputs

Create build description
Build description signature: b0dbcbb7e8fc7485c056026143b1c9c4
Build description path: /Users/administrator/Documents/UploadedProjects/<user id>/build/XCBuildData/b0dbcbb7e8fc7485c056026143b1c9c4-desc.xcbuild

warning: Building targets in manual order is deprecated - check "Parallelize build for command-line builds" in the project editor, or set DISABLE_MANUAL_TARGET_ORDER_BUILD_WARNING in any of the targets in the current build to suppress this warning
/Users/administrator/Documents/UploadedProjects/<user id>/B4iProject.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions is 11.0 to 16.2.99. (in target 'B4iProject' from project 'B4iProject')
error: The armv7 architecture is deprecated. You should update your ARCHS build setting to remove the armv7 architecture. (in target 'B4iProject' from project 'B4iProject')

Error: ** BUILD FAILED **
This is from trying to compile a B4i project that is totally unchanged from 2 days ago, when it worked.