iOS Tutorial FirebaseNotifications / Push Messages (server not required)

Discussion in 'iOS Tutorials' started by Erel, Jul 5, 2016.

Thread Status:
Not open for further replies.
  1. dealsmonkey

    dealsmonkey Active Member Licensed User

    In the fcm_connected is subscribe to ios+general, I am getting a PushToken:1 from the log and a token is being generated. If I send from firebase it shows as completed, but no devices.

    My b4j app log is this :

    Code:
    Waiting for debugger to connect...
    Program started.
    [jobname=fcm, success=
    true, username=
    , password=, errormessage=, target=class b4j.example.main
    , taskid=
    1, req=anywheresoftware.b4h.okhttp.OkHttpClientWrapper$OkHttpRequest@133314b, tag=java.lang.Object@b1bc7ed
    , httputils2service=
    null]
    {
    "message_id":7452680364343505248}
    Thanks in advance.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    You mean ios_general, right?

    This is not relevant. Don't use Firebase console.

    The message was sent successfully.
    Are you using the exact code from the tutorial?

    Have you tested it in both background and foreground modes?
     
  3. dealsmonkey

    dealsmonkey Active Member Licensed User

    Ok, thanks. I have checked the code but will do so again. I have tried foreground and background. I will keep checking, thanks for your input, it is appreciated.

    Neil
     
  4. dealsmonkey

    dealsmonkey Active Member Licensed User

    Just one thing is, you mentioned in an earlier post about checking the aps.cer file and the bundle ID. When I look in the aps.cer, my bundle
    Ok, I have sorted out my problem :oops::oops::oops: = analytics.Initialize

    I had forgotten to initialize the analytics. As soon as I did the messages came through :)

    The good thing about this, is I now understand the Apple Certificate, provisioning system a lot better !!!!

    Thanks for your help again.

    Regards

    Neil
     
  5. Melek

    Melek Member Licensed User

     
  6. Melek

    Melek Member Licensed User

    Hi, I have this error when compiling the App, could you help me?
    I followed all the steps as in the tutorial
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    Please start a new thread in the questions forum and make suret o include the complete logs.
     
Thread Status:
Not open for further replies.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice