Italian Il file ... non esiste !

LucaMs

Expert
Licensed User
Perlomeno al primo avvio... impiega una vita (sta in fase di "booting" già da almeno 3 minuti) e succhia parecchio tempo CPU:

upload_2019-9-18_17-45-33.png


e la ventola... sventola, soffre!
 

AlpVir

Well-Known Member
Licensed User
Ho appena utilizzato GenyMotion scegliendo il primo template (Google Pixel 1920x1024 se non erro) con Android 9. Ho caricato il mio apk, ho avviato l'app e 2 orari su 3 funzionano ! Il terzo (quello che non funziona) è stato caricato solo parzialmente, ma può essere un problema di lentezza delle operazioni on line.
Sembra proprio che la semplice riga nel manifest sia stata decisiva.
Adesso pubblico l'app e nelle prossime ore saprò se il problema è stato risolto.
N.B. Io ho indicato API 29, ad abundantiam
Grazie dell'assistenza. Ti terrò informato.
 

AlpVir

Well-Known Member
Licensed User
Io non ho avuto problemi di caricamento di GenyMotion. Forse perchè ho scelto una versione online mentre tu hai scaricato l'intero pacchetto. O sbaglio.
 

LucaMs

Expert
Licensed User
Io non ho avuto problemi di caricamento di GenyMotion. Forse perchè ho scelto una versione online mentre tu hai scaricato l'intero pacchetto. O sbaglio.
Potrebbe anche essere una grande differenza tra pc, il mio è vecchio di circa 7 anni, con win7!
 

AlpVir

Well-Known Member
Licensed User
A me sembra strano. E' vero che ho un portatile con i7 a 2.8 GHz ma la differenza di prestazioni mi sembra ingiustificata. Gatta ci cova. Io ho utilizzato "Google Pixel 1080x1920" e nel giro di 15-20 minuti avevo già terminato il mio bel collaudo.
 

LucaMs

Expert
Licensed User
A me sembra strano. E' vero che ho un portatile con i7 a 2.8 GHz ma la differenza di prestazioni mi sembra ingiustificata. Gatta ci cova. Io ho utilizzato "Google Pixel 1080x1920" e nel giro di 15-20 minuti avevo già terminato il mio bel collaudo.
In effetti scegliendo quel modello ha impiegato pochi secondi (anche se non vedo una Home sull'emulatore, almeno per il momento, vedo solo delle icone-menu sulla destra).
 

AlpVir

Well-Known Member
Licensed User
Mi è stato or ora confermato da un paio di utilizzatori che adesso l'app ORARIO SCOLASTICO funziona anche nei loro smartphone che hanno Android 9.
E' stato sufficiente inserire nel manifest la riga :
CreateResourceFromFile(Macro, Core.NetworkClearText)
 

LucaMs

Expert
Licensed User
In effetti scegliendo quel modello ha impiegato pochi secondi (anche se non vedo una Home sull'emulatore, almeno per il momento, vedo solo delle icone-menu sulla destra).
(Dovrei scrivere questo in un thread a parte, ma non credo che altri avranno questo problema, avendo molto probabilmente hw (pc) più recente).

Leggendo questa FAQ:
https://www.genymotion.com/help/desktop/faq/#virtual-device-window-empty

dopo aver aggiornato il driver della mia scheda grafica, il problema non si risolveva.
Come consigliato sempre in quella pagina, ho effettuato il downgrade di GenyMotion (vedi link in quel testo) e adesso pare tutto a posto (non ho ancora installato alcunché sull'emulatore).
 

LucaMs

Expert
Licensed User
Perfetto, appena aperte le impostazioni... crash dell'emulatore.
Gran bella soluzione, quella consigliata da GenyMotion stessa, ovvero di effettuare un downgrading del loro sw; in questo modo l'emulatore con Android 9, che avevo preparato con l'ultima versione di GenyMotion, effettivamente viene avviato bene ma va subito in crash alla prima "operazione" che tenti.

Questo si spiega perché una volta effettuato il downgrading, l'elenco dei dispositivi "emulabili" arriva solo fino ad Android 8.

:mad:
 
Top