.ini error

WizardOz

Member
Licensed User
Longtime User
Hi!

everyday I boot up my computer and start basic4android I get an message "error loading .ini file". Even when starting up as administrator.
If I start basic4android again (not rebooting) no errors is generated.

My only workaround on this has been to take an copy of the .ini file (with my settings) and copy it into the Roaming directory when I get the error after an reboot. It then works as expected with no errors.

I hope, however, there is a fix for this. Copying the .ini file isnt much job, but its one of those annoyanses that get tiresome.

Here is the facts:
Computer: Eee PC Seashell series
System: Windows 7 starter
Mem: 2gig
Basic4Android: licensed (payed for)
The working .ini file looks like this:
B4X:
Left=-8
Top=-8
ClientSizeWidth=600
ClientSizeHeight=600
FontName=Candara
FontSize=9.75
FontBold=False
WindowState=True
TabSize=4
WordWrap=False
AutoSave=True
TvSubsWidth=228
ShowToolTips=True
DesignerTopMost=False
IncludeDebug=True
AttachDebugger=True
NumberOfRecentFiles=0
MaxRamForDex=512
OptimizedDexerPort=36729
DesignerDesktopPort=36728
DesignerDevicePort=5000
ProcessesTimeoutSeconds=30
SignKeyFile=
SignKeyPassword=
B4ABridgeIp=
DebugDesktopPort=12121
PlatformFolder=D:\Android\android-sdk-windows\platforms\android-8
ToolsFolder=D:\Android\android-sdk-windows\tools\
JavaBin=C:\Program Files\Java\jdk1.6.0_21\bin
AdditionalLibrariesFolder=

Everything about Basic4Android is working perfectly, its just this .ini error getting on my nerves.
I hope you got a sollution! :confused:
 

WizardOz

Member
Licensed User
Longtime User
Have you tried deleting the ini file? Basic4android will create a new default one.
If it doesn't help, please send me the problematic ini file to [email protected].

Its actually NOT the .ini file that is the problem.
Maybe I was making myself unclear, let me break it down:

1: REBOOT
2: B4A complains about having trouble reading the .ini file
3: B4A then makes a new one.
4: I delete this "new one" and replace it with the older one with my settings in it.
5: B4A then starts with no problems, using my older .ini file.
6: I can then start B4A lots of times without problem as long as I DONT reboot.
7: If I reboot, see point number 1... :)

The .ini file was the file I had in my earlier post, but I will attach it in this post.
 

Attachments

  • b4aV0.1.ini.txt
    681 bytes · Views: 260
Top