Bug? iOS 15 Beta 4 Error Message

yaldineh

Member
Licensed User
Did anyone try to install the B4i-Bridge on iOS 15 Beta 4? I get a message saying "The developer of this app needs to update it to work with this version of iOS" I get this message with the app I created also. No other apps installed on my phone display this message. Any idea how to get around it?
 

Erel

Administrator
Staff member
Licensed User
It should work with builder2 now. If you get builder1 then choose the secondary builder in the builder settings.

builder1 will need to be replaced so it will take some time.
Edit: both builders were updated

Developers using a local Mac: It looks like macOS Big Sur will soon be required for iOS development.
 
Last edited:

yaldineh

Member
Licensed User
It is working, the only part is that I had to make Identifier xxxx.bridge, then make a provision for to be able to download the Bridge App, and after download the Bridge app, I used the original identifier for debug.
 

ilan

Expert
Licensed User
Developers using a local Mac: It looks like macOS Big Sur will soon be required for iOS development.

very bad news, i have a mac mini late 2012 and i will not be able to upgrade to Big Sur.
i just bought (2 days ago) an extra 8GB for my mac mini.
i really hope there will be a workaround :confused:

 

moster67

Expert
Licensed User
The upgrade to Big Sur on Mac Mini late 2012 is not supported.

Seems it might be possible to upgrade not in an official way:
https://github.com/BenSova/Patched-Sur


I did not test it on my late Mac Mini 2012. I bought a new Mac Mini M1 instead.
 

ilan

Expert
Licensed User
I bought a new Mac Mini M1 instead.

are you satisfied with the M1 chip? Developing with b4i is no problem with the new chip M1?
 
Last edited:

Erel

Administrator
Staff member
Licensed User
are you satisfied with the M1 cheap? Developing with b4i is no problem with the new cheap M1?
Both remote builders are with M1 chips. They are faster than the Intel based Macs.

Note that Apple released a new version of their chips which is faster (M1X I think). It is still not available with the Mini, but it will probably be at some point.
 

ilan

Expert
Licensed User
Note that Apple released a new version of their chips which is faster (M1X I think). It is still not available with the Mini, but it will probably be at some point.

thank you for that info, then i think it is better to wait until it is available. i like the mac mini it is small and cheap compared to a mac notebook solution.

ps: i just noticed that i wrote cheap instead of chip. I attribute this to the fact that I have not drunk coffee yet. ☕
 
Top