Android Question Issue with WebView and Pages from Node-RED

Discussion in 'Android Questions' started by MarkusR, Oct 2, 2018.

  1. MarkusR

    MarkusR Well-Known Member Licensed User

    it seems that webview can not display pages from Node-RED server (v0.19.4). https://nodered.org/
    it looks ok in chrome browser but at webview it is just white.

    example page in chrome browser:
    Screenshot_2018-10-02-16-41-36.png
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Is there any public page that we can test?
     
  3. MarkusR

    MarkusR Well-Known Member Licensed User

    the white page is displayed 30 seconds in web view then a connection lost notify appear in web view.

    just for test please:
    link removed
     
    Last edited: Oct 3, 2018
  4. Erel

    Erel Administrator Staff Member Licensed User

    Same here. Looks like it uses a long polling socket that doesn't work with WebView. Maybe you can configure the server to switch to regular WebSockets.
     
    MarkusR likes this.
  5. MarkusR

    MarkusR Well-Known Member Licensed User

    i did not found something about i opened a question in node-red forum.
    thank your for investigate.
     
  6. MarkusR

    MarkusR Well-Known Member Licensed User

    their answer was:
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice