Bug? layout file not found error

Discussion in 'Bugs & wishlist' started by qsrtech, May 17, 2015.

  1. qsrtech

    qsrtech Active Member Licensed User

    Seems like ever since 4.x I get file not found errors when saving new layouts with uppercase letters. Weird thing is old layouts saved with uppercase letters load no problem.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Please post the exact steps required to reproduce this issue.
     
  3. qsrtech

    qsrtech Active Member Licensed User

    Go to designer.
    Create new layout.
    save layout with upper case letters. for example the last one I did was "RoundUpDialog"
    use the new layout in LoadLayout
    bam. File not found error

    I do see a warning issue that the file was't added to the project. Not sure why it isn't but when I rename it to something else without upper case it loads fine.
    I've also seen something like this in b4i
     

    Attached Files:

  4. Erel

    Erel Administrator Staff Member Licensed User

    Works here with no errors or warnings.

    Is it possible that you have manually copied the file to the Files folder (from a different project)?
     
  5. qsrtech

    qsrtech Active Member Licensed User

    Nope. I add a new layout to my existing project through the designer. And like i said earlier, b4i has the same issue. Always works when i use only lower case.
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    Lets focus on B4A for now.

    Can you make a screencast video, starting from a new project that demonstrates this issue?
     
  7. qsrtech

    qsrtech Active Member Licensed User

    I'll look at it Tomorrow. It's pretty much bed time now.
     
  8. qsrtech

    qsrtech Active Member Licensed User

    Ok, I think I have figured out the steps to reproduce.
    Create a new project
    create designer file. Name it with UpperCase
    load it in the activity

    The interesting thing I found was that when I added a layout file using "add file", it seemed to work just fine. Upon further testing while writing this, I realized that when using "add file", it renames the "bal" file within the OS with all lowercase but seems to maintain the upper case format within the IDE. I'm using win7.

    P.S. Upon further investigation, the test attached won't do much good because the "export to ZIP" process seems to rename the "bal" file all lowercase. Basically it seems to me the designer is supposed to save the file all lowercase (while maintaining the format within the IDE) but it isn't.

    P.P.S. and this would appear to be the same issue/cause in b4i as noted above.
     

    Attached Files:

  9. Erel

    Erel Administrator Staff Member Licensed User

    Everything you wrote is by design. One thing that is not clear from your description is what happened when you created the layout file with the designer. The expected behavior is that the file is saved as a lower cased file.

    If it is not the case then please create a short screencast that shows it.
     
  10. qsrtech

    qsrtech Active Member Licensed User

    Attached Files:

  11. Erel

    Erel Administrator Staff Member Licensed User

    Thank you. I'm afraid that I'm unable to play this video.

    I've tried the process in both B4A and B4i. When you create a new layout file the saved file is lower cased automatically. Not sure why it doesn't work on your computer. This was always how it worked since B4A v1.00 and you are the first to report this issue.
     
  12. qsrtech

    qsrtech Active Member Licensed User

    Thank you. I will try to duplicate it on my laptop which is also win7. If i can duplicate it there then i will get a different way of recording the screen. Again, i don't know if this is only related to my dev comp but earlier i went back to my b4i (conversion) app and when i ran it i was getting all kinds of file errors (not layout ones, module ones). After about an hour or more, this situation got me thinking to export zip it and wah lah. After unzipping it to a new folder everything was back to normal (i did try just copying it to a new folder w/o success)
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice