B4A Library Leadbolt Ads

Inman

Well-Known Member
Licensed User
So how can I add a banner to the bottom of the app? Unlike Admob's Adview, LeadboltIWrapper is not a view and therefore cannot be added to an activity.
 

LeadBolt

Member
Licensed User
Some of you may already know but we recently released our SDK 4.0 which includes various enhancements such as:

- Audio Ads: the next dimension in ad experience which combines display, audio and a gyroscopic trigger to enhance user engagement and move the display ad experience beyond the limitations of the mobile screen.
- QuickStartAds: revolutionary and simple integration method that will allow publishers to load an App Ad (display ad eg. interstitial), a Notification Ad and an App Icon with just a couple of lines of code.
- Rich Media Ads: interactive rich media ads that conform to MRAID 2.0 standards.
- Enhanced Notifications: allows customization of text with the option of additional lines of ad text, customized icons or without icons.

If you'd like to learn more, please go to our blog posting detailing everything here.
 

alan1968

Active Member
Licensed User
hello,
Is it possible to remove the banner under certain condition ?

mybanner.destroyleadboltads ,no effect

thx!
 

Monkeh

Member
Licensed User
Can't display banner ad

Hi,

I'm having trouble getting the html banner ad to display. I've created a webview to display the ad in but can't get it to display.

I've tried this...

B4X:
webview1.JavaScriptEnabled = True
webview1.LoadHtml("<html><body> <script type="text/javascript" src="http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx"></script></body></html>")
and this...

B4X:
webview1.JavaScriptEnabled = True
webview1.LoadUrl("http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx")
The first won't work at all and the second just displays js code.
Do I need to use another lib to display js code properly or am I just not doing this right?
 

straybullet

Member
Licensed User
Is there no support for B4A on these new features?

Some of you may already know but we recently released our SDK 4.0 which includes various enhancements such as:

- Audio Ads: the next dimension in ad experience which combines display, audio and a gyroscopic trigger to enhance user engagement and move the display ad experience beyond the limitations of the mobile screen.
- QuickStartAds: revolutionary and simple integration method that will allow publishers to load an App Ad (display ad eg. interstitial), a Notification Ad and an App Icon with just a couple of lines of code.
- Rich Media Ads: interactive rich media ads that conform to MRAID 2.0 standards.
- Enhanced Notifications: allows customization of text with the option of additional lines of ad text, customized icons or without icons.

If you'd like to learn more, please go to our blog posting detailing everything here.
 

sdixon

Member
Licensed User
Hi,

I'm having trouble getting the html banner ad to display. I've created a webview to display the ad in but can't get it to display.

I've tried this...

B4X:
webview1.JavaScriptEnabled = True
webview1.LoadHtml("<html><body> <script type="text/javascript" src="http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx"></script></body></html>")
and this...

B4X:
webview1.JavaScriptEnabled = True
webview1.LoadUrl("http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx")
The first won't work at all and the second just displays js code.
Do I need to use another lib to display js code properly or am I just not doing this right?
This does display a banner ad in my app
B4X:
webview1.JavaScriptEnabled = True
webview1.LoadHtml("<html><body> <script type="text/javascript" src="http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx"></script></body></html>")
but when clicked on it gives a 404 error.

Does anyone have the same problem?
 

Androidsaetabis

Member
Licensed User
WebView1.JavaScriptEnabled = True
WebView1.LoadHtml("<script type=""text/javascript"" src=""http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx""></script>")
 

Stulish

Active Member
Licensed User
WebView1.JavaScriptEnabled = True
WebView1.LoadHtml("<script type=""text/javascript"" src=""http://ad.leadboltads.net/show_app_ad.js?section_id=xxxxxxxxx""></script>")
I tried this code but the webview just remains blank

What section id do you use, i have a different id for each type of add and an account section id?

Cheers

Stu
 

Androidsaetabis

Member
Licensed User
this code run ok

B4X:
Sub Globals
Dim WebView1 As WebView
Dim WebViewExtras1 As WebViewExtras
Dim WebViewSettings1 As WebViewSettings
Dim LeadboltNoti, LeadboltIcon As LeadboltXWrapper 
end sub

Sub Activity_Create(FirstTime As Boolean)

WebView1.JavaScriptEnabled = True
WebView1.LoadHtml("<script type=""text/javascript"" src=""http://ad.leadboltads.net/show_app_ad.js?section_id=318379370""></script>")

end sub
try
 

Stulish

Active Member
Licensed User
Androidsaetabis,

If i use your Section ID the webview ad shows correctly. I have tried all the section ID's in my Leadbolt dashboard and it never shows an Ad, the ones i have shown are:

App Ad (SDK) - App Ad #1, App Ad #2 and App Ad #3
Notification (SDK) - Notification #1
App Icon (SDK) - App Icon #1

and also mu user ID

How do i get a section id for HTML ads?

Regards

Stu
 

ssg

Well-Known Member
Licensed User
Stu,

When you click "add ad", you get that pop up with 2 tabs. One is SDK Ads, another HTML Ads. Do you have that?
 

Stulish

Active Member
Licensed User
On another note, how do people find Leadbolt?

So far i have been using it on one app that has been on the App store for just over a week with 260 downloads.

From Leadbolt i have had :

App Ad #1 - Interstitial (Chrome)

New Users = 1,587
Views/Imps = 1,620
Clicks = 174
ECPM = $2.84
EPC = 0
CTR = 10.74%
revenue = $4.60

The bulk of this was on day 1/2 where myself and friends clicked ads.

And i have noticed the ads are very repetitive for 4 days the same ad appeared every time.

So so far i can not say i have been very impressed as the selection of ads seems small.

the other point i have found is that it will show one ad, when you click you get taken to a different product (i think this is poor as people want to view the product they clicked on), and also some ads say not available in your country (but the add worked previously).

So i think Leadbolt have a few bugs/problems to sort out.

That said it has only been a week or so.

Regards

Stu
 

ssg

Well-Known Member
Licensed User
Hey Stu,

Those are not bugs / problems, it is how these ad networks maximise it for their advertisers. Sending out fake ads and such. Gotta get used to it.

Also get used to the same few ads appearing everytime. It happens with all networks, even the almighty admob.
 

Stulish

Active Member
Licensed User
When i click the HTML ad, it opens in the small webview i use for the actual ad.

I have selected Open Clicks In *: New Window in the edit app banner section.

Any ideas??

Thanks

Stu
 

Stulish

Active Member
Licensed User
Since i have added HTML banners the Interstitial Ads have stopped????

if i remove the HTML ads the Interstitial don't come back.

How odd?
 

Stulish

Active Member
Licensed User
Bill,

I added the sub and change wv to webview1 (the name of the webview in my app).

and still the same thing happens?

Thanks for all your help :)

Stu
 
Top