iOS Question Local Mac Building - Keychain Error

Discussion in 'iOS Questions' started by MurphmanL, Apr 3, 2015.

  1. MurphmanL

    MurphmanL Member Licensed User

    Hi all,

    I seem to be having a problem using my iMac 'local mac builder' configuration with b4i.

    I have started the server on the iMac and it is broadcasting. I then try to connect on my windows machine, which does work successfully. However, I get an error when trying to compile the b4i app for installation onto the iPhone.

    I have I believe followed the steps in the 'Installing B4i Bridge' Guide, so I have the following in my keys folder of b4i - mobile provision file, certsigningrequest.csr, mobile provision file,B4i keystone files.

    However, when I compile the B4i Bridge app, I get recognition of the compile on the iMac saying 'Adding user to keychain :lee" and then B4i comes back with the error -

    'MAC verification failed during PKCS12 import' (Wrong Password?)

    I'm so confused, not sure I recall putting a password in anywhere apart from into the Private Key file, but if this is the password its referring to where do I specify that for the builder?

    Apologies if this is a daft question I am just becoming lost after reading the tutorials.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Do you have access to the hosted builder? If not then I will send you a temporary id so you can start with the hosted builder and once everything works move to a local builder.
     
  3. MurphmanL

    MurphmanL Member Licensed User

    Hi Erel
    Thank you for reaching out to me with this kind offer. It would be good to have access to the hosted builder temporarily to get me going if you don't mind. Thank you :)

    However as you can appreciate the reason i didn't opt for the service is because i do have a mac with xcode. Long-term it would be useful if you are able to provide any suggestion to solve my keychain error(have i missed some sort of keychain step on the mac)?
     
  4. MurphmanL

    MurphmanL Member Licensed User

    Hi all,

    Just to update that I went back into the developer console, re-generated o sthe provisioning profile and key and then loaded the key into keychain on the mac. I have since now been able to install B4iBridge, and started debugging. Unfortunately, B4i crashed and upon opening it again I'm now told that it can't find a valid 'pair of provisioning key and profile under the profile specified'.

    Going to re-generate the key and profile again - hope I won't have to do this every time I want to open the b4ibridge debugging!
     
  5. MurphmanL

    MurphmanL Member Licensed User

    Hi All,

    Just to advise I have managed to resolve this - it appears to have been an issue with the key I generated from Apple.

    After starting again from scratch the builder now works first time, everytime and I've been happily porting my B4a app over the easter break.

    Just going to open another thread now as I've got some questions :) Thanks for your help Erel.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice