Android Question NB6 Notifications Builder class (2018)

Discussion in 'Android Questions' started by Mike Oink, Aug 6, 2019.

  1. Mike Oink

    Mike Oink New Member Licensed User

    I installed the NB6.zip and ran it unchanged on my Nokia 6 with Android 9 and it worked for most examples for the first time. But not for "animated", "with progress" and "with actions" - even on first start.

    On second and following start, only "High priority", "Low priority" and "custom sound" gave a notification - all others did nothing at all.

    I've tested it with debug-mode and also in release-mode.
    In debug there was not any log to see. It seems to be a non-event for those notifications.

    The device is connected via USB.
    Is there something to be resetted after it has been ran the first time ?
     
    Last edited: Aug 6, 2019
  2. Erel

    Erel Administrator Staff Member Licensed User

    Your device probably uses a custom theme that doesn't work with these features.

    Try to change the package name and test it again.
     
  3. Mike Oink

    Mike Oink New Member Licensed User

    I deinstalled the App on my device. After deinstalling and run again it works.

    Thank you for your reply. Probably the change of the package name would have solved the problem too.
    Nokia uses nearly pure Android 9.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice