No resource identifier found for attribute 'hardwareAccelerated' in package 'android'

BarrySumpter

Active Member
Licensed User
Longtime User
I get this with the ABBarcodeTest.b4a

Any suggestions as to what this might be so I can fix it in this app and any more in the future?
 

NJDude

Expert
Licensed User
Longtime User
Check the AndroidManifest.XML and if you see this line:
B4X:
android:hardwareAccelerated="true"

Remove it.
 
Last edited:
Upvote 0

NJDude

Expert
Licensed User
Longtime User
Why are you using "do not overwrite manifest"?, what B4A do you have?, you don't need to do that if you're running 1.8 or 1.9

I ran that sample and I had no errors.
 
Upvote 0

BarrySumpter

Active Member
Licensed User
Longtime User
1.9 n working with custom urls.
just dl n tested n as u posted all is ok.

Checking all projects again now.
Will zip n post the project that gives me this error.
If I find it again.

OK. Attached.

And your fix fixed it.

I'm sure it was me getting confused.

Thanks for the support.
 

Attachments

  • ABBarcode Test Orig.zip
    12.8 KB · Views: 283
Last edited:
Upvote 0

NJDude

Expert
Licensed User
Longtime User
The problem with the project you attached was:

1- You have "Do not overwrite manifest file" setup, I removed that.
2- You have a label (Label2) defined but there's no Label2 added to the activity, I removed it.

After doing that it worked.
 
Upvote 0

BarrySumpter

Active Member
Licensed User
Longtime User
Cool.
Thanks again for your support.
Can't tell you how heavy that was trying to figure out Custom URLs.
Me being a noob n waiting for all to return from Easter holies n all.

Still sorting out the rest of my project and will post my findings as soon as I finish.
 
Last edited:
Upvote 0

PhilN

Member
Licensed User
Longtime User
Thanks NJDude. I had the same problem with the jPCT demos and just removed the hardwareaccelerated=true using the manifest editor and Boom Baby! It worked! Thanks Pal! :)
 
Upvote 0

Informatix

Expert
Licensed User
Longtime User
Thanks NJDude. I had the same problem with the jPCT demos and just removed the hardwareaccelerated=true using the manifest editor and Boom Baby! It worked! Thanks Pal! :)

Since jPCT-AE uses OpenGL, I don't think that turning HA on or off will change something but most of the time it is better to let this setting to true. Your problem is that you probably not set the Android.jar path to:
C:\Android\android-sdk\platforms\android-17\android.jar
in your B4A configuration.
 
Upvote 0

raphipps2002

Active Member
Licensed User
Longtime User
Brilliant....thanks it was simply not pointing to android-17....forgot about that since I installed a year ago...much appreciated
 
Upvote 0
Top