Android Question Packaing Files Error (nothing to do)

Jeffrey Cameron

Well-Known Member
Licensed User
Longtime User
I tried to reply to a thread about this (back on Sept. 9th) but it told me the thread is too old to reply to and I haven't seen any thread with a solution since. So, here's another new thread:

Prior to version 8.50 of B4A, I have been using a NAS drive (mapped to a letter in Windows 10). Since installing B4A 8.50 I cannot compile any app located on the NAS without getting this error:
B4A Version: 8.50
Parsing code.    (0.02s)
Building folders structure.    (0.25s)
Compiling code.    (0.11s)
Compiling layouts code.    (0.01s)
Organizing libraries.    (0.04s)
Generating R file.    (0.12s)
Compiling debugger engine code.    (1.76s)
Compiling generated Java code.    (1.88s)
Convert byte code - optimized dex.    (1.67s)
Packaging files.    Error
NOTE: nothing to do
If I Close B4A, then move the project folder to my secondary local hard drive, reopen the project from the local drive it compiles just fine. I never had an issue compiling a project located on the NAS (or a Windows server mapped drive) in earlier versions of B4A.

For what it's worth, this isn't game breaking for me, just annoying due to the extra step to pull/push the folder from the NAS so I can be sure the project source gets backed up. Perhaps GIT support in version 9? ;)

Jeffrey Cameron

Well-Known Member
Licensed User
Longtime User
Does v8.50 / SDK v26 add one or both of those by default? This is a simple test app that I created when I started having problems going through and re-compiling my original libraries for TargetSDKVersion=26.

After having issues compiling, I created a brand-new project in B4A v8.50 and added a new (standard) class. Copy-and-pasted the class code from the non-compiling project to the new project. Still failed to compile.

The only referenced libraries are Core, Reflection and StringUtils. Here's the manifest, it should be default:
'This code will be applied to the manifest file during compilation.
'You do not need to modify it in most cases.
'See this link for for more information:
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="26"/>
<supports-screens android:largeScreens="true"
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
CreateResourceFromFile(Macro, Themes.DarkTheme)
'End of default text.

The project will not compile if the project file folder is on my NAS (Netgear ReadyNAS 424) which I am logged into as an administrator. If I move the project file in its entirety to my local hard disk (C: or N: ) and then open it and compile it, it compiles with no errors. And as I said, the original project used to compile fine in its original NAS location with B4A <v8.50 and TargetSDKVersion <v26.
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
I tried to move one test project to server. B4A 8.50, targetSDKVersion = 26, uses JavaObject (and , of course, Core).
I logged as administrator on local PC and server.
I tried two variants: to open using assigned to shared folder letter and using UNC path. Both works fine.

One thought ... Take a look x.b4a in Notepad. Maybe something strange in ModuleX lines ?
When you want to add existing module, B4A offers - "copy to folder", "relative link", "absolute path".
Upvote 0